Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sidekick 89 TBI swaped?
#1
First of all, Congratulations for this great and helpful site! I just found it and I can't stop reading...

Second...my apologies if this thread is treated on another post, if that's the case please erase this post and I will keep searching...

I just bought a '89 Sidekick Manual, A/C, 4x4, 8V... in pretty bad shape, but trying to get back to best possible conditions.

The engine runs good once is warmed around 800 rpm (after 1 min o so) but I have to keep my foot on gas pedal for that time, otherwise it tries to die. 
I can't turn on the AC anytime because the rpm drop down to almost die. No rev up with headlights are turned on neither. 

I assumed I had problems with iddle throttle opener valve...but I realized it doesn't have one... no ISC, EGR not connected at all, No EGR Mod and no VSV valves, IAC (I think is the IAC) broke, one tube are cancelled,  it is a totally mess... 

I realized it didn't have VSV valves and I said, ok, I got the vsv valves but once I analized, there is no way to connect them since No EGR Mod, or Iddle Advancer...

After some research got more confussion, since IMHO the TBI is not the right one for this model, I found one at a Junk Yard (which is different to actual mine, but it looks more like I have seen in images) but Im not comfortable thinking on maybe the intake manifold is not the correct one neither..

The Tag next to the battery shows nothing, it appears it is erased by time, the diagram under hood show the vaccum diagram for California. 

Any help would be greatly appreciated

Thanks in Advance.

Cheers from Cabo

PS. Images of my actual TBI are attached


Attached Files Thumbnail(s)
                   
Reply
#2
(06-13-2019, 05:07 AM)CaboSidekick Wrote: First of all, Congratulations for this great and helpful site! I just found it and I can't stop reading...

Second...my apologies if this thread is treated on another post, if that's the case please erase this post and I will keep searching...

I just bought a '89 Sidekick Manual, A/C, 4x4, 8V... in pretty bad shape, but trying to get back to best possible conditions.

The engine runs good once is warmed around 800 rpm (after 1 min o so) but I have to keep my foot on gas pedal for that time, otherwise it tries to die. 
I can't turn on the AC anytime because the rpm drop down to almost die. No rev up with headlights are turned on neither. 

I assumed I had problems with iddle throttle opener valve...but I realized it doesn't have one... no ISC, EGR not connected at all, No EGR Mod and no VSV valves, IAC (I think is the IAC) broke, one tube are cancelled,  it is a totally mess... 

I realized it didn't have VSV valves and I said, ok, I got the vsv valves but once I analized, there is no way to connect them since No EGR Mod, or Iddle Advancer...

After some research got more confussion, since IMHO the TBI is not the right one for this model, I found one at a Junk Yard (which is different to actual mine, but it looks more like I have seen in images) but Im not comfortable thinking on maybe the intake manifold is not the correct one neither..

The Tag next to the battery shows nothing, it appears it is erased by time, the diagram under hood show the vaccum diagram for California. 

welcome , and the site fixkick is not new its is now 12 years old today,  and not owned by me our run by me, but I still post in this forum best I can.
That is very wise of you to post pictures, as I do see many things very wrong, there.  mixed up years. of parts, and damage and defeated key devices.
photo1 shows calif EGR there,  (no problem with that the ECU will not use the sensor there)
need your ECU model number on sticker of the ECU,   33920-60A32 is correct, never  56B30 is 91-95 USA.
TB shows is off 92 to 95 car, and is wrong, I will tell  you later what will happen with wrong, TB and wrong TB has wrong Injector too.
The car has 2 VSV (89 has no EVAP CAN, VSV) only Dashpot and EGR< and EGR is not needs if not running yearly smog checks are you >?  no location stated.
The TB ISC is wrong, and damaged up front connector broken off and hot water (coolant lines are missing) (a bad idea in cold weather, ) 
someone stole the DASH post making startup fast idlle dead (1/2 dead) and wants to flood or not start is the door prize.
The ISC coil in side (its is really and air valve solenoid) coil resistance. is not the same as 89 at all putting the ECU at risk. 89 to 91 but 91 to 89 will cause it to run wrong only.
the injector wires are with Scotch tape, ouch.
Looks to me the PO , prev, owner did all he could do to make it fail using wrong TB is that.  but yah 30 year old TB are hard to find now, super hard, car-part.com many find one.
there are 3 idle controls here to fail,  wrong and dead ISC up top, IAC thermal in the base of TB and Dashpot missing and last the missing or wired wrong DIODE BLOCK seen in the link below DIFFR page.

I need photo of hood sticker?  up and under, there, this is the USA EPA tag the tells  me for this hood (LOL) what car was new.

The ECU model number. the VIN code like this,,,   JxxxxxxxxxxxNNNNNN 9 show all X data but last 3 digits (that is serial) at the end. for privacy.  if made in JAPAN the J in front tells that, and more.  The vin is located funny, one left drivers do and is on outside dash edge not top like 91+ , very oddly placed. this VIN.

a photo of you distributor, is nice, as was radically changed in 91 up. 
The early cars 89/90 the ECU does not produce spark at all. only does fueling and my not like that TB at all with its unique injector there.
89 distributor  has vacuum advance, (not 91+) and makes its own spark all by it self, and has its own centrifugal weights inside, for RPM full advance that can jam up easy)
89 all engine tune up steps are different (EFI ) spark timing and idle speed all very very different,

who knows ? the car may be 91 drive line , ecu, harness in 89 body, only photos tell me that fact. (not enough yet)
I also see that intake manifold is off a A/T car,with matching vacuum nipple port not jury rigged closed, for trans automatic, so that too was changed but what if whole engine was changed, well that is easy peazy lemon squeezy..

the engine serial number is next.  on the left rear side at the bell mount is  serial code like this, G16Lnnnnnn ( L means letter in an the USA is the YEAR engine was made) tell me L code.
this new forum one can insert any image,  way more easy this is where all G16 have this serial, outside USA the coding is different. so. if not USA say so.... ok"?
we match that with the VIN to see if either is WRONG. or unmatcheds, super easy checks here, VIN and engine s/n/

[Image: engine-sn-w1.jpg]
http://www.fixkick.com
Reply
#3
the ECU tag on 91 looks like this, if 89 the 56b is 60A coded.
see the US mark for USA, this means it runs USA smog devices.  THAT "AT: mean for automatic trans, yours will show "MT"  for manual trans.

[Image: tag3.jpg]
we need to know this so we can see what degrees the last own swapped in wrong parts.  (desperate for sure)

now if learn 91-98 sidekicks well this  funny list makes sense, this is my 89/90 differences page and is prime information on why wrong parts work wrong.

The early 2 years have vast differences, they look kinda same but see here.

https://fixkick.com/specs/89-diffs.html
http://www.fixkick.com
Reply
#4
that is a calif car for sure, firewall plate is for color only codes to help autobody shops . paint
the hood proves its calif and has calif EGR and 89, calif EGR and full vacuum hoses match year 89..
ok i see you have what I call the PIG tail IAT, sensor, (no plug at sensor) just pig tailed wired, so is a 1989/90 manifold, so only the TB is wrong.
engine number is next.
thanks for showing all that, nice TAGs and clear too. very good.
i see that 89 distributor there with vacuum CAN. so is 89/90 for sure, that.
so only the intake is wrong for A/T box, (no big deal that) and wrong TB.
the 89 has no ISC coolant pipes so that is why PO cut them off.
and looks like this. if my identify page.
https://fixkick.com/sensors/89/89-vacl-map1.jpg

https://fixkick.com/sensors/89/89-throttlebody.jpg

https://fixkick.com/sensors/89/89-TB-exploded1.jpg

see this. the 91 sensors are different,.
https://fixkick.com/engine/8v/vacuum%20p...age_2.html
http://www.fixkick.com
Reply
#5
I guess we crossed on our comments...

Thanks my friend!

As I told you before, I found a TBI on a junk yard, presuumed coming from a '90, I compared it with your image and it mached appareantly... woul you just do a quick view if I'm correct?

Another question I just saw a long screw instead of 2 where the cover of tbi is secured, is that a  big deal?

Cheers!


Attached Files Thumbnail(s)
                   
Reply
#6
that looks to me like "BIG CHALLENGE"
the long screws are metric and sold everywhere. (autostores or web screw stores)

but no lie 30 year old TB are not easy to find and for sure good.

3 only here.... super rare... is the word.
http://www.car-part.com/cgi-bin/search.cgi
http://www.fixkick.com
Reply
#7
best is to put auto search on ebay for this and see what pops up, week by weak, luck can happen.
you can have it cleaned with walnuts shell blasting... no damage no sand, no glass beads.
http://www.fixkick.com
Reply
#8
You are totally right!

I will be on my searching for a TBI, and I will keep it posted my progress...

Keep up the good work!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)