Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thermal IAC
#1
Hi All,

On my G16B engine out of a 1994 suzuki sidekick jlx:
I tore apart my throttle body because I had been experiencing a bog on cold start.
I can easily find the throttle body gasket, but I am having trouble finding the Thermal IAC rubber gasket.

Where can I find and order a new one?
If I need to buy a new thermal IAC, where can I find that?

Thanks!
Reply
#2
(09-03-2019, 04:32 AM)Akull Wrote: Hi All,

On my G16B engine out of a 1994 suzuki sidekick jlx:
I tore apart my throttle body because I had been experiencing a bog on cold start.
I can easily find the throttle body gasket, but I am having trouble finding the Thermal IAC rubber gasket.

Where can I find and order a new one?
If I need to buy a new thermal IAC, where can I find that?

Thanks!

I THINK YOUR  thermal IAC is ok , cold idle 1200, is that.
hand made gaskets, using and exacto knife,NAPA see, blank gasket material

bog at cold start, check fuel pressure first.

and the IAC can be tested in hot pan of water,
at 150F it closed, fully, and for sure 180f, but 150f is spec.
http://www.fixkick.com
Reply
#3
Hi, thanks for the prompt reply!
I was able to seal up my throttle body/thermal IAC
Still experiencing the issue where the idle drops and comes back from cold to hot engine.
So I guess its a bog on cold start?

Fuel pressure seems ok according to your tests. 40psi with key on, engine off, 34-36 psi with engine running hot.
Only thing that seems odd, is when the gas pedal is tapped, fuel pressure jumps to 60 and drops back down.
Does that seem normal?

Thanks again for any and all help!
Reply
#4
(09-15-2019, 10:37 AM)Akull Wrote: Hi, thanks for the prompt reply!
I was able to seal up my throttle body/thermal IAC
Still experiencing the issue where the idle drops and comes back from cold to hot engine.
So I guess its a bog on cold start?

Fuel pressure seems ok according to your tests. 40psi with key on, engine off, 34-36 psi with engine running hot.
Only thing that seems odd, is when the gas pedal is tapped, fuel pressure jumps to 60 and drops back down.
Does that seem normal?

Thanks again for any and all help!

that 60 is wrong , 60 is shunt pressure, with FPR, stuck closed.  bad FPR, if 60 is real.
the key on pressure was 40 and that is normal and then at idle is 35 is ok.
but when you WOT the throttle, the pressure will go here  40 but not exactly, it will try to reach 40  on this car.
The 60 is only the shunt valve ,like when you block the return hose on the FPR.
Sounds like the FPR is bad. to me. (its sticking inside, does the vacuum port to it leak fuel if yes the FPR is bad.


here is mine at sea level 16valve engine. only. yours  is 4psi higher, and that is ok.  so 40 on your car would be max. for key on and WOT, (near)  green in imperial measurement USA.

[Image: reg-graph-mpi-g.jpg]

60psi is when the pump works in to a dead head,  into a fuel line 100% pinched off or clogged.  show the pump working nice sure. but FPR NOT. (spec max pressure is 43psi per FSM and is key on only spec)
http://www.fixkick.com
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)