Suzuki SideKick Repair Forum
Stumbling on acceleration - Printable Version

+- Suzuki SideKick Repair Forum (https://www.fixkick.com/bbs2/Suzuki-bbs)
+-- Forum: Repairs (https://www.fixkick.com/bbs2/Suzuki-bbs/forumdisplay.php?fid=1)
+--- Forum: Sidekick/Tracker Forum (https://www.fixkick.com/bbs2/Suzuki-bbs/forumdisplay.php?fid=2)
+--- Thread: Stumbling on acceleration (/showthread.php?tid=2505)



Stumbling on acceleration - five20too - 06-25-2019

Well I've been having issues with stumbling on acceleration. I had the issue before and never got it resolved so I parked it for a while and I'm messing with it once again. Starting off this time I changed the spark plugs, rotor, cap and wires. I also drained the tank and replaced the fuel filter. That did nothing. Then I removed and cleaned the EGR and checked it and it was good. No change. Then I put in a new FPR and it didn't change anything. New Airtex E2000 and no change. The thing is that I can, and I know it's not suggested, put my vice grips on the fuel return hose and it runs like a scalded ape. If I run it without that it won't even pull itself out of a ditch. I hooked up the reader to it this evening to check some live data and found that my STFT and LTFT were way off. STFT was about 25 at idle and LTFT was about 20. LTFT fell to 0 once I revved it up to 2500. It bogs then drops. I believe STFT went up to 32 at the same rpm. I haven't checked fuel pressure yet. I guess I'll go buy a gage set up tomorrow and try and check it at the rail. This engine is in my Samurai and I don't have the sidekick filter installed. Thanks for any help you can offer.


1996 Suzuki Sidekick 1.6


RE: Stumbling on acceleration - fixkick - 06-25-2019

frankensammi. sure.
pinch return and 60psi happens. (the shunt test) this makes pressure 2 times normal and over injects same so is a valid test.
fpr does this. (this is normal , as you advance the throttle the vacuum drops and fuel pressure rises the same amount,
https://fixkick.com/INJECTORS/PUMP/reg-graph-mpi-g.jpg

that test proves the injector x4 are clogged.
or proves ECU underjects (pulses to the 4injectors)
THE MAF weak or only dirty is first.
LTFT will reflect the fact that fueling is lean. and slam trim full rich. (if 02 shows it going lean LTFT goes rich correcting this state. if not controllable it rails the LTFT and sets a DTC error for going off the rails, I call it.
forget STFT it moves faster than humans can see, only LTFT matter, slow and usefull to track.
the O2 sensor failing , most times cause rich not lean. (0v O2 causes full rail rich)
MAF tops list of causes, this is the primary fueling device here, #1 top dog.

The ECT needs to be at 300 ohms or 180F degrees hot, the scans show what it is.
the ECU scans show maf air flow too, but is a chicken and egg test. very hard to test. most times cleaning it works best.
one trick is to unplug the mAF and the MAF simulator inside the ECU (firmware) , causes more FAKE maf air flow and engine wakes up. DTC errors happen now dead maf, and limphome effects.

https://fixkick.com/sensors/92-95MAF/92-95-MAF-testing.html


RE: Stumbling on acceleration - five20too - 06-26-2019

Ok I started with the MAF since that's what I understood to be the most likely culprit. I did unplug it like I read above and it ran good. I removed it and cleaned it with some CRC MAF cleaner. Once I reinstalled it I cranked it up and it fired right up. No usual stumbling around. It ran good for about a minute and then threw a P0102 code (Mass or Volume Air Flow A Circuit Low). Tried clearing it a few times but it returned immediately. Now I'm wondering if cleaning it somehow exposed an issue and allowed it to throw the code, or perhaps, it wasn't totally dry. I did let it sit for a while and I didn't see any moisture. I do have another engine here that I can pull a MAF off and swap it to mine. Maybe I'll try that tomorrow.


RE: Stumbling on acceleration - fixkick - 06-26-2019

(06-26-2019, 12:44 PM)five20too Wrote: Ok I started with the MAF since that's what I understood to be the most likely culprit. I did unplug it like I read above and it ran good. I removed it and cleaned it with some CRC MAF cleaner. Once I reinstalled it I cranked it up and it fired right up. No usual stumbling around. It ran good for about a minute and then threw a P0102 code (Mass or Volume Air Flow A Circuit Low). Tried clearing it a few times but it returned immediately. Now I'm wondering if cleaning it somehow exposed an issue and allowed it to throw the code, or perhaps, it wasn't totally dry. I did let it sit for a while and I didn't see any moisture. I do have another engine here that I can pull a MAF off and swap it to mine. Maybe I'll try that tomorrow.

first may I say , 2 problems,  can be hard to diagnose. ( p0102 mean maf is dead a 0 volt output to ECU, keyon nostart MAF output pin is 1vdc not 0v.)
In this case,  not doing fuel pressure first, 
if the car had bad gas, because car sat for 2+ years and fuel went bad or tank filled with rust , and the injectors clogged up
  1. then the FPR pinch test shows power returns,?
  2. and the maf pulled off line test shows power returns.?
both tests, cause false  and illegal fuel pressures or false longer injector pulses respectively,  hiding or masking whole and in part, clogged up injectors. (1/2 clogged , oh boy hard)
see?
I must say both tests,  1 and 2 are both wise , prudent and expedient, to finding real problems. 

idle speed 800rpm fuel pressure is, (30-37 psi)
wot fuel pressure is  36-43 psi,  same as keyon no start. note the 6 psi rise.!! the FPR job1.


RE: Stumbling on acceleration - five20too - 06-26-2019

I'm not gonna lie. The fuel filter was orange and the fuel looked rough when I changed it. I'm sure some could have gotten by and partially clogged an injector. Is this a Sea Foam clog or a remove injector and clean out kind of thing? My local parts store is putting together a fuel pressure tester gauge for me. Of course they didn't have the 14x1.5 fitting on hand.


RE: Stumbling on acceleration - fixkick - 06-27-2019

well the injectors can all be cleaned, by reverse flow ultrasonic cleaning
each injector has 10 micron screens (size) 4 times smaller than the missing filter in front of tank,.
filter is 40micron (best brands)
sea flom is lies,
tell me how a solvent can disolve iron oxide, metal....dust. ? (feO2)

the injectors are $22 each here.
with before and after flow test DATA.

https://www.witchhunter.com/

or refurb injectors, set.
cleaning them on car is super hard, unless only clogged up with green slime, (old fuel turns to slim) but rust that is super hard to clean , if not reverse flowed.


RE: Stumbling on acceleration - five20too - 06-29-2019

Sorry I haven't reported back but I got really busy this week. Thanks for that link above. I will definitely have to send off my injectors to get them cleaned. On a side note, I did take the MAF off my other rig, cleared the code and started it. I don't ever remember it starting that easily or running that smoothly! No more code and it has plenty of power now. I guess I never thought the MAF could make it seem like a fuel starvation issue, but once you do some reading, it lets you know that the ratios get all mixed up when the MAF isn't measuring the air volume properly. Thanks again for all of your help and I hope that maybe this will help someone else!


RE: Stumbling on acceleration - fixkick - 06-29-2019

(06-29-2019, 09:26 PM)five20too Wrote: Sorry I haven't reported back but I got really busy this week. Thanks for that link above. I will definitely have to send off my injectors to get them cleaned. On a side note, I did take the MAF off my other rig, cleared the code and started it. I don't ever remember it starting that easily or running that smoothly! No more code and it has plenty of power now. I guess I never thought the MAF could make it seem like a fuel starvation issue, but once you do some reading, it lets you know that the ratios get all mixed up when the MAF isn't measuring the air volume properly. Thanks again for all of your help and I hope that maybe this will help someone else!

great news
and a spare at home making this easy
the MAF is not fun or easy to test, can be if you had a flow bench, (LOL) or vacuum cleaner shop, sized huge or a leaf blower, to get 3vdc or more out of it, see my maf page for how.

sure am glade it runs right !! cheers