Is your engine flooding ?:              EFI ONLY                            
Also known as, Over-fueling . (Can be, the under supply of air ! at idle)
A.k.a. My motor, is running way too rich  or worse!    
See Jargon used here.
Black exhaust cloud, or the CAT glowing red hot, or worse, the whole exhaust manifold glowing red hot?
You smell the gas rich BLACK  cloud?
The 1996+ USA cars, CEL lamp flashes when driving... (means the CAT is melting, operator guide says go slower and get it serviced)
The CAT smells funny? or odd ?  Gross misfiring and loss of power, and MPG at 12MPG. Stalling? or won't start?
The engine shakes violently at idle, due to the gross misfiring.....Lots of Symptoms!
Jet black spark plug tips, full of carbon, and sometimes dripping with raw fuel.
See my macro reasons ,here.

See common fails for rich running caused by ( The O SENSOR) here.


The fast track?
Plug on left is hopeless!   Carbon + raw fuel.   
Good is cream, tan or white, not black.
These are raw fuel  fouled spark plugs, and is a clear sign of gross over fueling.
Over fueling is caused by:
(Super macro list !)  
A Gross overview , A global view !  


The best way to solve this riddle,  is to knock off the first 2 below, good engine that has spec. compression and good steady vacuum and good spark + timing.
That leave, just 2 things, ECU is being lied to, or the injectors are messing up , due to their being bad or fuel pressure is stratospheric.  60psi  hard fail.
This list a short top failure list:  (from the universal list, bad motor, bad spark, bad fueling, in that order)
This block is called BASIC's:
Flooding, is when the engine overloads with fuel, so bad, the spark plugs foul and will not fire.
Liquid fuel conducts electricity so good , it shorts out the spark plugs. So does carbon, conducts even  better. (dry them out?)
A bad motor can be, very low compression, bouncing vacuum, EGR stuck open or exhaust closed off due to a melted CAT converter.
The melted Cat can be tested with a vacuum gauge.
If the engine can not pump air, it is bad , no matter the cause. "it must breath (intake) fresh air" to be and engine.
Keep in mind if the stock engine with 150PSI compression is now at 75 PSI, the EFI system will over fuel this 1/2 sized engine. (8valve for sure)


The "SUPER SECRET UN-FLOOD MODE" : (in the operators guide,

UN-FLOOD:  ( this always works, if the injectors are not stuck open)
Pressing the Gas Pedal (accelerator) to the floor boards, activates , secret ? Unflood mode of  ECU and helps greatly. " CUTS FUEL WHILE CRANKING"
Unflood, mode, causes the ECU to stop all fuel injections, while cranking.  ( but spark continues, as normal)  (THIS CAN CLEAN THE SPARK PLUGS, too)

There is another trick? with the engine cold and not flooded yet, start the car with just a touch of gas pedal (5%-10%) this adds just a little more air to the start mix.
This don't work on fully functional EFI, but does if say the IAC fails. or leaking injectors, In fact, this trick makes good engines/ EFI, harder to start.
This might be all it takes to get a good start.  This is not normal. So, if this trick works , you do have a problem. ( ISC stuck closed, IAC stuck closed? whole or in part)
This trick works best on a HOT RESTART because the IAC is closed hot and the the ISC provides all fresh air, in this case, the ISC may be sticking closed.(hot starts)
The problem is too much fuel or it is too little air , that gas pedal is really an AIR PEDAL. If the IAC an ISC stuck closed,  or the EGR is stuck open the engine can flood.


Super Macro:   (a level 2 expansion on the above.)

  1. Bad motor ! (a cam belt slipped)  or clogged and melted CAT, bad compression, vacuum low and fluctuation (bouncing) madly) Bad head valves.
  2. A Bad EGR , the EGR is leaking and causes horrible idle speed misfire/stalling and flooding or spark plug fouling.  (idle RPM will be way too low)
  3. Coolant never warms up to 180F and holds ,  the Thermostat is  bad, wrong, installed wrong, or missing.
  4. A Motor frigid , makes motor rich.( see TSB warning on that, and such and easy fix.)
  5. ECU over fueling due to bad inputs to ECU   (MAP , MAF and ECT , and 0 sensors (hot rich only) are the top contenders)
  6. Way too high, fuel pressure,  30 PSI is right, 60 is way bad and will cause flooding in a flash.
  7. Bad spark.  (statistics show: 41% of all out of warranty cars, never get any tune up service at all , gee, try a IGNITION  TUNE UP)
  8. The spark not only must be static timed (about 5BTDC) but the advance must move the strobe off the scale at 2500-3000 RPM ! if not fix that now.
  9. Leaking Injectors.  (injectors on MPI can clog or leak, making ECU a little nuts., the ECU will make it worse, by over fueling , a sad weakness in the design.)
  10. Induction air losses ,.  This is an IDLE issue only.  (a hot motor with a dead ISC will flood due to lack of air supply)
  11. Unknown and bad modifications to the Engine or total EFI system. (look  for wiring and parts transgressions) Motor swap damage is common.
  12. Bad ECU,  only years 89-95 are subject to First time CAP failures, of the large internal electrolytic Capacitors (the Rubicon Cap's disease)  96+ NEVER FAIL.
  13.  A bad 0 sensor. Hot running only, (or ANY air leaks near it will make it read wrong , due to cracks in the Exhaust headers/collectors& O tests and common fails.
  14. A Melted and closed off, Catalyst Exhaust unit. (render the engine useless)
Usually I see rich  and then use my scan tool to see if a sensors reads wrong and if true?, I work that angle.
Then I make sure the engine can hold closed loop/ if not?, I trouble shoot that failure next.. More on that later (below)
I tune up the engine and then put in a fresh new 0 sensor , if  the 0   is over 80k miles old or suspect, one can be had for $20.


The ECU can not function correctly when inputs to it, are grossly in error.  (or its output slave devices (actuators) are bad/weak,jammed, leaking or dead.
The ECU does report sensor that are grossly in error, via the DTC reporting, but with scan tool you can see the full story.

The Micro VIEW: (the fine details )  "no order"  I can't see, smell or hear or feel your car run, but I can show all the reasons for flooding.
Flooding is caused  by: (  This is just a hit list read on for tests.)  AND A FULL  TUNE UP IS ALWAYS FIRST. Do the 60K mile list.
I hope I covered every type of fail for flooding. (I cross fingers)

MY SAE JARGON PAGE IS HERE:

You can check Ignition timing while cranking with the strobe timing light and the Freeze jumper in place and see the static timing on the engine 5 Deg BTDC.
open hood, look up , see vacuum map (EPA MAP) see timing spec.!

If timing is way off , the Timing belt HAS SLIPPED ! DON'T CHANGE Distributor timing , correct the BAD TIMING BELT !


TEST's:  8V TBI only G16A

There are many things, that can cause flooding:
Safety first:
Make sure your (8 valve  only example) Injector O-rings are not cracked ! and leaking? key on 3 times , look in the air horn . The my not leak , just key on, ever.
  • Pull the MAIN INDUCTION  air tube between  the Throttle body and  the air cleaner  (not on a 16v)
  • Look down the Throttle BODY air horn,  and see injector, while looking at it, have a helper turn the key on , NO start, repeating 3 times.  DO NOT CRANK ! (off , Key-On, off, repeat).
  • If massive gas floods way down bore, then the injector o-rings are bad. (I use a dental mirror to see if it's the injector or the 0-rings leaking)
  • If , however, you see this tiny little squirt (or nothing) from the injector during the 3 second FP run, then this test passes.  This is called the prime pulse, some cars can have tiny squirt others none. most cars no squirt, this prime pulse is to purge only air from the lines, after servicing car (eg:fuel filter)
  • This can happen with 20 year old injector seals , they cost about $5 to change  (seen in my part to buy parts page)
  • If you have an MPI , 4 injectors 16v engine, then this test is much more complicated, then test the injectors fully.
  • 16v MPI motors ,check for 1 injector flooding only 1 cylinder (spark tip wet?) , (proof of single injector fail) follow this lead ,using my injector pages.
  IF YOU DISCOVER BAD INJECTOR O-RINGS, STOP AND DO NOT PROCEED BELOW, CORRECT THE PROBLEM. < a serious safety issue here.
If you let it, fill a combustion chamber  (#4 is lowest) with pure fuel over  35cc or more the hydra locking can bend the rods. (end game)

#1
cause's of FLOODING is a bad need for a tune up.   (Cap, Rotor, wires, and plugs) and a fresh Air Cleaner filter and that fuel filter too.

Test 2:  All motors. with 4 cylinders soaking wet  plugs, and sparks look like photo above.
Kill the fuel pump one of these ways ( I always pull the Left Rear tail light connector.)_
Crank motor and  you burn off the flood cylinders of raw fuel,with the fuel pump deactivated (it may start then die, now that fuel pump was killed by you.)
Then, once sure spark it good  and motor is dry , we use test fuel.  squirt test fuel into the EVAP nipple on the top front of the induction plenum camber.
Crank motor over and it will start.  Do so 3 times to get the feel of how motor runs on test fuel. It runs good now...then stalls from Test fuel burn up.
If it does run and sounds good and runs for 3 seconds and you can repeat this over and over and it always starts easy and runs good we can check off a bad motor.
If test 2 passes we must assume the  ECU is over fueling  or  there is under air conditions, at play.
ECU over fueling?  (we use a scope in the shop to see it over fuel at the injectors.)
or you can have leaking injectors, do the fuel pump leak down test to find leaking injectors.
On the 16v we do 3 test on the injector,besides NOID lamp tests. and scope tests ,we do the fuel pump leak down test on my pump page then do the 2 balance tests.
The pump leak down is here.    The balance test is here, and you can pull 1 injector connector at at time on a running motor to see I one cylinder is dead.
That being said, fuel pressure can be  too high, ECT readings too cold (10000 ohms at ECT cold, is way too cold and motor will flood !)
Make sure the IAC is open cold.   and that the ISC is not jammed shut.
You need to check all inputs to ECU if ECU is the cause of over flooding ( injector pulse widths way too high, over 3mS, is cause for concern)
The 0 sensor can not cause cold folding so scratch that off  the list. The 0 usually comes on line, 10 seconds after a cold start.
 

Test 3: Basics
Before guessing, it is best check the engine basics first, especially on a 16 valve engine.
Below, are all the things that can go wrong:
If you check your Ignition timing with a timing light ( with the freeze timing jumper placed) and discover the timing is off by more than 2 degrees.
Please stop and validate the cam timing, if not and you have a 16 valve engine , your engine could be destroyed.
This lack of starting, may be a large miracle, that saved your engine for destruction.  Bad becomes good!
{ any high mileage 16v engine that is acting FUNNY , needs to have its Timing Belt Validated for correct timing and lack of damage }


DO NOT SPIN the Distributor (willy-nilly) back and forth to start the engine, this only confuses the ECU more.. Use a timing light ( a $15 tool)
If you find spark timing way off, a good idea is to assume the cam timing belt slipped.
Why?, well the Timing belt has slipped and then the ignition timing went with it ( see gear from Distributor to cam ,they are linked by a 2:1 ratio).
This caused the engine to not run, due to low compression AND bad ignition timing,  
To find this common failure (never doing 60k tune up's is the cause)
The fast check for this is here, do our sneak-a-peek test, on the  cam belt timing. ( unless you know it is brand new and OK)
The engine can not run with bad cam timing and bad spark makes burning fuel impossible.

While doing that , check the crank pulley for looseness and torque it to 94 Ft/Lbs
( there is a TSB raising this torque,so forget any old shop or store bought  manual, it will be wrong)  (see two links above for torque  TSB)
If the 17mm head bolt on the crank pulley was discovered to be below 50ft/lbs (very bad) I do the inspection.  I use a beam torque wrench , and if bolt moves below 50, oops.
LEFT HAND BOLT (CCW = looser)
One just watches the scale, as you turn CCW and see where the bolt starts to move.  Anything below 50 ft / lbs , is way too loose.  and HIGHLY SUSPICIOUS !
Yes, you must lock the flywheel (or use 5th gear (M/T) + brakes set) to torque said crankshaft bolt.
It is advisable to visually check the crank pulley key way for damage.  On all new to you, Sidekicks, to your home/garage.
A one time ever , inspection and TSB correction.  I use the mild blue liquid Loctite on the big bolt threads.
If there was looseness , you must check the CRANK SNOUT FOR KEYWAY DAMAGE !

See my idle pages for things that can stick and cause loss of fresh air.

The Fast Track?
You can see that the list is huge. (imposing , no?) I never work this list (but is in my mind) , what I do is this, once I find a Hot  RICH running motor.
Cold start flooding is a whole different matter.
Water temperature at 180F or better and holding all the time hot.  If not stop, and fix that.  do not pass go , do not collect $200. stop and fix the bloody THERMOSTAT.
I get the EGR closed at idle., Compression test?,  Vacuum test?,  I then  do the Cat back pressure test, and the full 5 step fuel pressure and leak down test.
I look for near the 02 sensor ,exhaust leaks. and induction leaks (16v). and correct them first.  I make sure my ECU is NOT IN LimpHome !!!
Last (or first if you have one) , I connect a scan tool and check all inputs to the ECU , I make sure the ECU enters Closed loop status HOT,  if not , I find out why?
A pro checks the tail pipe emissions and sees a hot motor running rich , he then connects the scan tool, to see if ECU , sees this rich or is causing it and why.
He has a scope and can see the 02 sensor is stuck lean.   (he replaces it and it's still lean, he finds the header gasket, well, missing,or collapsed after 20years of abuse)
He finds the 16v #4 exh header tube cracked, like all other thousands of kicks.
The ECU scan tool will show 2 things wrong.  (at least) Closed loop is DOA, and LTFT is railed.  LTFT at -25% ?  (the ECU is trying to remove fuel but can't get there.....)
I help people fix EFI and Carbs,many (1/2) don't want to use a scan tool and the carb guys, don't want to get wet in gas, examining the carb, float levels or real cleaning !
No tests, no glory.
No tools, no success.

Fast track 2:   I will show many fails here not just flooding. Any failure , at any time can cause limphome it happen ,& that is near flooding.
Using a scan tool: Here are my scans
Examples and the reasons all, in 1 line.  (one liners)  (some produce DTC errors, I am looking at just at the sensors, and doing my tests to find the solutions below)
I see the O2 sender stuck lean and AFR max rich, LTFT at +43% , creaked #4 Exhaust down tube, hidden under shield. LTFT is +43% and CAT melting.
ECT shows, 120F for 180F water.  ECT was bad.  (my IR pyro gun shows 180F water or more)
MAF dead seen by scan tool. ECU in limphome Dead MAF  mimic mode active, and rich  , 02 rich all the time.(truth)
Thermostat missing (hopeless) ECT shows 140F temp all the time ( it is). or colder if ambients are cold. new Stat works.
0 sensor shows, rich fill time,  the fuel pressure was found to be at 60PSI. a stuck FPreg. LTFT at -34%   "Long Term Fuel Trim" an OBD2 PID , parameter.
0sensor is psychotic,  I find  #1 injector leaking full time.
0 railed lean, due to dead injector, on #2  , each misfire causes the 02 to see that huge slug of air, and the ECU adds Fuel (LTFT at +43%) (ECU hates misfire)
Keep in mind, every intake stroke of the piston , sucks in 20% oxygen and if that jug don't FIRE , that 20% slug, rails(grossly) the 02 to LEAN.
This  bad karma causes all jugs to go rich. "flooding"  There is only one  O2 sensor, to the ECU messes up all the other 3 for one bad jug.  (like slugging, ones self)
OBD2 limited this effect to less rich in 1996.
0 shows LTFT of +25% adding fuel all time time, I find an air leak in my EGR base gasket (broken and sucking air) (16 engine ).
same 0 , and readings, but my 8v single injector is partially clogged and ECU keeps adding more fuel to no avail. car bogs.
0 on my 8v TBI shows, rich but LTFT shows huge -34% fuel being subtracted, near flooding,  the injector 0-rings leak like crazy or fuel pressure on the moon.
Off topic: but...
I'm getting P0300 random misfire.  I find  a huge air leak in my huge top air pipe to the MAF.  It's Not flooding here ,just showing LTFT actions and causes.

What is flooding , really ?  The MACRO VIEW !
It is caused in just  2 way:
1: Bad motor / Spark
2: Over injection, even though #1 is perfect. (EFI flooding)  "electronic fuel Injection"

The EFI system as 2 weaknesses, It don't know the motor or spark are bad , so mindlessly injects fuel.  (this is all I need to know!)
The engines EFI system is tuned to inject fuel on "Swept Volume", so if compression is at an anemic 80 PSI (1/2 normal),  you effectively have an 800 CC motor.
The 1.6Liter sucks 400 CCs of air and fuel each 180degree's of crank rotation , this is  swept VOLUME.
This  fact causes, the ECU to over inject, the engine, because it does not know about the lost compression and injects for 1600CC displacement.
The same is true if the spark fails, the fuel don't burn and the cylinder floods,
If spark is Bad,  that is dead, weak, crossed fire timed,or not timed perfectly as my pages shows, then the fuel will no burn and the fuel stacks up.
This fuel keeps adding up and  floods and fouls the spark plug and they get far wetter, the longer you crank the dog over.
Bad Engines come in a number of forms. Most bad motors, are discovered by a simple classic compression test at W.0.T. (wide open throttle) and a vacuum test.

The Last way to flood #2 above ,which is, direct EFI caused flooding, that is, the Engine and spark are perfect, but  is caused by: (a short list)
  • A disconnected ECT sensor. "the Engine Coolant Temperature, sensor" (goes to Limp home mode)
  • 60 PSI  fuel pressure (Fpreg  bad) "the fuel pressure regulator"
  • The injectors are leaking.
  • or clogged injectors; on the  MPI motor that misfires (the ECU sees 02 lean and adds more fuel , causing good cylinders, to now flood)
  • The EFI is in LimpHome, usually caused by a bad sensor (MAF?) and usually the ECU is telling you this with stored, DTC errors, (look ! CEL on running?)

To fully understand, EFI read Jeff Harmans book, on topic.

Ref#1: Swept volume.
If the compression is real low the swept volume is not compressed the normal density of air and fuel, this cause the fuel to not burn completely.
As much as 1/2 the fuel goes unburned and this stacks up (builds) The spark plugs turn blacker and/or  get soaking wet with raw fuel.
80 PSI compression is way too low. It's a bad engine, so is 100 PSI.  170 is minimum on the MPI and 150 is minimum on the TBI motor.

Every time a cylinder misfires, a slug of unused oxygen is expelled from the jug (can) and this oxygen hits the 02 sensor and shows lean , just the opposite of reality.
This is a weakness in the EFI design. When all the fuel burns,each  bang, so does all the  Oxygen in the air slug.

ver 12 , 12-10-2012  more links.