Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
91 Beloved Sammi, running uber rich...
04-15-2019, 11:20 AM
Post: #1
91 Beloved Sammi, running uber rich...
Need advice, have a 91 Sammi, fresh overhaul, mild cam ran good last summer. Had it in the garage over the winter, now it is running really rich. During the overhaul it got a new gas tank and fuel pump (old one quit, getting it out we saw the tank wasn't so good, replaced both). Wondering if the fuel pressure regulator may be bad since it's getting too much fuel. I checked the return line from the regulator to the tank, seems open. Not sure how to test the regulator... and it's $90-140 depending on where you price it. Thought I would ask you before spending that much $$...
Find all posts by this user
Quote this message in a reply
04-15-2019, 10:43 PM
Post: #2
RE: 91 Beloved Sammi, running uber rich...
what engine is there?
what EFI is there if not EFI its a carb, what fuel system is this?
sound like TBI injection,
the regulator is tested, for presssure, fuel line presssure,
using presssure guage, and is based of altitude, not throttle angles

did you check the ECU for DTC error codes yes, flash codes (blink)? that is first.
if he ECU is in limphome mode it will run rich as pig even with 3 new FPR regultors replaced.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
04-17-2019, 10:07 AM
Post: #3
RE: 91 Beloved Sammi, running uber rich...
It is a 1.3 TBI engine, I have a fuel pressure gauge and will check that tomorrow. It is flashing a 24 code, it has since we rebuilt it.
Find all posts by this user
Quote this message in a reply
04-17-2019, 10:34 AM
Post: #4
RE: 91 Beloved Sammi, running uber rich...
24 mean the VSS sensor in the speedo head is dead. (vss = vehicle speed sensor)
is the speedometer dead or missing?





(04-17-2019 10:07 AM)Plainsman79 Wrote:  It is a 1.3 TBI engine, I have a fuel pressure gauge and will check that tomorrow. It is flashing a 24 code, it has since we rebuilt it.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
04-18-2019, 09:07 AM
Post: #5
RE: 91 Beloved Sammi, running uber rich...
The speedometer is intact and reads speed and mileage, had a rain delay today to read fuel pressure.

When I read it at first I had the output of the pump into the pressure guage, rather than T'd into the line. I got 70 pounds into the gauge, then it backed off to 0 as it read the load and backed off. I need to read the pressure with the gauge T'd into the line.

(04-17-2019 10:34 AM)fixkick Wrote:  24 mean the VSS sensor in the speedo head is dead. (vss = vehicle speed sensor)
is the speedometer dead or missing?





(04-17-2019 10:07 AM)Plainsman79 Wrote:  It is a 1.3 TBI engine, I have a fuel pressure gauge and will check that tomorrow. It is flashing a 24 code, it has since we rebuilt it.
Find all posts by this user
Quote this message in a reply
04-21-2019, 08:15 AM
Post: #6
RE: 91 Beloved Sammi, running uber rich...
I may have fixed it. While working on it this week I removed the fuel regulator and cleaned it with penetrating fluid and carb cleaner. It seemed as though it was an over-pressure problems as it was spitting fuel out of the tailpipe. Anyway, had a rain delay, worked on it today with my son, inserted the fuel pressure into the line, had 32lbs when it was running.

It ran much better though, took it for a test spin and it seems back to normal! Going to run some sea foam and more fresh gas in it tomorrow and drive it to work this week. If that happens again I may shell out the $$ for a new fuel regulator... Also downloaded a FSM for the 90-94 Sammi's, will look there tonight to see if the fuel pressure is listed.
Find all posts by this user
Quote this message in a reply
04-21-2019, 10:14 AM
Post: #7
RE: 91 Beloved Sammi, running uber rich...
my fuel pump page shows how to do all that as does the manual on the CAR FSM
you did one of 5 tests,. the shunt test a pump man (water?) would call it a dead head test.
60 PSI is normal 70 mean the pump is very strong, and no leaks in the in tank hoses.
seaflom is snake oil never use that.

the key on pressure or idling is ,34 to 41 PSI and is Altitude base ONLY) G16: TBI pressures

see the factory pages, see the drawing with the pressure gauge on the filter banjo screw, 6mm thread, maybe your filter is NOT STOCK ? IDK


http://www.fixkick.com/INJECTORS/pump.html

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
04-21-2019, 10:15 AM (This post was last modified: 04-21-2019 10:17 AM by fixkick.)
Post: #8
RE: 91 Beloved Sammi, running uber rich...
all suzuki books show at least 4 or more fuel pressure tests and FPR tests.

shunt
keyon
idle
wide open throttle (no change on this car)
and leak down test,

ever book in print show that, and more if 16v, (complex lots more)

all 10 years of ours do this
ever one.but yah , some cars are hacked up.

[Image: TBI-conn-1w.jpg]

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
04-21-2019, 10:27 AM (This post was last modified: 04-21-2019 10:32 AM by fixkick.)
Post: #9
RE: 91 Beloved Sammi, running uber rich...
here is my rich list , huge.... try for you.

1: in limphome mode ECU, CEL flash codes not 12 flashes.
2: fuel pressure out of spec, not is not per above.
3: injector leaking or hacked wires to it to gawd knows what.
4 :any of 2 injector 0-rings leaking on actual injector in TB.
5: O2 bad, or exhaust cracks near it cause it to go NUTS (sets o2 max lean 0volts and ECU goes MAX rich)
6: if the Distributor has no cmp like this 94 has, that means it has advancing weights inside that can freeze(rust) and MPG is horrible.
7: Map bad or hose to it clogged or cracked. map never fail only vacuum to it fails for all the reasons, even the nipple source vaccum clogged or susuki silly filters on this hose clogged up.
8: spark timed wrong, or spark bad , coil bad, wires HV bad , spark plugs bad. cap rotor bad.
9: vacuum leaks are no it, well except to MR, MAP.
10: cam belt slipped. or was timed wrong last service 60k point.
11: CAT melted, if car has full power this is not it.
anything else would be super obvious air filter packed in crap or critter nets from end to end, air intake.
12 :compression very low. 150 par wide open throttle.
13: ECT bad, reads 10,000 ohms hot engine, not 300 and will burn a tone of fuel ever time. I call this stuck in ALASKA mode.

that is all I can think of top of head. late.

this may match ours, its 1994 sammi
unflood mode is cranking only cuts fuel, if ecu sees spark end it cuts fuel running.

[Image: late-sammi-efi-94.jpg]

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
04-21-2019, 10:36 AM (This post was last modified: 04-21-2019 10:37 AM by fixkick.)
Post: #10
RE: 91 Beloved Sammi, running uber rich...
if you suspect an injector partial clog, get Chevron Techron for injectors, in a bottle for gas tank this a power benzine solvent.
do not put oil or anything like oil in the fuel or risk wrecking the CAT.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)