Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Misfire, but no DTC's?
#1
Hello!

Similar to Ropadopa, I recently acquired a 1996 X90 – I got mine from a co-worker, and it has what appears to be a pretty good misfire when the throttle is applied quickly. He had been troubleshooting it for some time, and finally gave up after he could not resolve the issue. I had been looking for a G16B to put in my Samurai, so he sold me the X90 for next to nothing to get it out of his garage. The car drove fine for approx. a year after he got it, but about six(?) months ago it started acting up with the misfire condition. Just short of 90K on the odometer. Rebuilt/salvage title.

Feathering the gas pedal will allow it to rev to redline with no issues, but anything more than a moderate press on the pedal results in the misfiring condition. It will eventually stumble up to about 3000 RPM and then rev up normally. If the pedal is fully floored at idle, it will pretty much chug and burp until the pedal is lifted. The exhaust smells like it is running rich when misfiring, but it is not putting out black smoke. The fast idle at cold start works normally, but at idle when warm, there is a slight intermittent misfire.

Reviewing the forum posts for similar conditions here, and consulting a borrowed FSM from the previous owner (PO), this is what I have checked so far:

Compression check (warm eng, WOT): #1 – 185#; #2 – 195#; #3 – 187#; #4 – 186#
Engine vacuum is 21” Hg and steady;
Installed Bosch cap, rotor and wires;
Ignition timing with freeze jumper is 6 deg., crank pulley bolt is tight, but I did not verify cam timing marks;
No cracked exhaust manifold tubes;
PO installed new cat;
FPR testing: Key on – 39#; Idle – 33#; Key off – 31.5# and will hold it for well over one minute. Applying 26” Hg to FPR nipple shows 31# (should be 21#?) Have not done shunt test (pinched vacuum line to FPR).
EGR valve responds (tries to stall engine) when diaphragm is pushed, FSM live EGR test shows normal ops;
Removed and cleaned dirty throttle body, which helped, albeit minimally.

The PO had a low dollar code reader and said that the car had generated a P0300 awhile back. I bought a Autel Autolink AL619 scanner as it will read some live data. It showed no DTC’s stored, or pending. It shows that the TPS appears to be working normally with key on, engine off. Using the live data feature, I generated this readout using all PID’s available (see attached file).

The data can be downloaded and printed out as a text file and it is output in ‘frames’, which are cumbersome to compare – for me - with all the pages generated. I entered all of the data into the attached MS Excel file for easier review. RPM is highlighted in a red font, and I highlighted “Frame 15 & 16” where the induced misfire condition was taking place.

What the data shows is 15 seconds at idle, 15 seconds at 1500 RPM (trying my best), 15 seconds at 2500 RPM, 15 seconds at 4000 RPM, then 15 seconds to stabilize at idle. Then 10 seconds with the gas pedal floored, causing the misfire (frames 15 & 16), then a final 15 seconds to stabilize at idle again.

Using fixkick’s Full OBD2 scan info, some of the values look OK, and some have me scratching my head, as I don’t really know what all the parameters are indicating, and the manual does not explain what each PID is showing. I have done several engine runs with the scanner connected while learning the scanner and then generating the aforementioned data file, but it has not yet thrown any DTC’s, other than the ones I have intentionally caused by disconnecting MAF and TPS connectors.

That brings me to drive cycles – I have not tried capturing any live data while driving since driving it with the big stumble is sketchy with normal or heavy traffic. The only driving I have done with the vehicle was the 15 miles to get it home, late in the evening. The FSM says that “A driving cycle consists of two parts, engine startup and engine shutoff.” Is driving the vehicle the only way the ECU will be able to generate any DTC’s?
THE ONLY ERROR HERE IS NO TRANSMISSION STATED.


Attached Files
.xlsx   X90 OBD2 Data.xlsx (Size: 12.45 KB / Downloads: 5)
Reply
#2
welcome,
nice data !, but only 1 parameter in this xls file can I figure out RPM in red.
are you logging metric,? where is ECT data in C" 90C ? line 9 ECT?


id need you to put each sensor name for each line (ok you did that)
yes, many DTCs are 2 or 3 driving cycles, but pendings , are limited to 1 at a time. so weak that.

NO TRANSMISSION STATED?
NO SPARK PLUGS STATED (J PLUGS AND GAO SETTING)?
NO country stated, USA or Canada, the ECU is not the same in both countries, so I must ask country,sorry.
No new FUEL filter?
IS TANK FUEL BAD, IS IT OVER 15% FULL, IF NOT DTC do not set for P0300.
NO outdoor temperature stated. please tell me that.

WHY IS COOLANT AT 94c AND NOT IN CONTROL? i bet the engine is still warming up at frame1, but way does it hit 94C and does it hold at 94c.NO ! frame 17 says thermostat is out of control or its rubber ring is missing on outer edge for STAT,
if the STAT has no rim the STAT floats in the 4mm deep groove and will NEVER regulate, (due to buying wrong stat and using 92-95 wrong STAT>)
see why here, called Ice Berg city, wrong parts or the test down in very very cold day and radiator is overtaxed,(too much air flow)
http://www.fixkick.com/Cooling-engine/Fr...r-cab.html


here it is ( best EFI pages and engine manual) see part 1, 2,3,4 those are all DTC fully documented by suzuki then reprinted by GEO. ALL DTC fully covered here.
here:
http://ge.tt/6gvplbp2

I can not see O2 readings live, 2D, at frame15, my tools lets me loop scan the 02 sensor.
The O2 if lean at F15 is staving for fuel, (filter clogged, or injectors clogged) but no loop scans done yet (B1S1) only looped 2d mode. simulated scope view I call it.

yes p0300 is all cyl, misfiring but the rules for setting 300s is trick, even fuel tank over 15% full.
all spark parts new> (is see full tune up below but not plugs? gaped to 0.028" never use out of box gap it is always wrong.at 0.045" says NGK

or bad coil. inside distrib,?

filter ok and fuel pressure ok at frame 15?
then
if the injectors are clogged, we can prove that , with propane gas. not LIT. feed it a snort of propane gas in the intake at (IAT sensor port?) on air cleaner box. and see if it wakes up, at the BOG point, if yes, injectors are clogged.
http://www.fixkick.com/tools/Propane-tester1.jpg
( a normal propane nozzle, unscrewed and host attacked works same as this OTC tooL))

clean it first.
the MAF can be tested with a voltmeter, on the output pin easy. type maf in my fixkick, search box. super easy testing MAF

http://www.fixkick.com/sensors/92-95MAF/...sting.html
http://www.fixkick.com
Reply
#3
(12-13-2018, 08:36 AM)fixkick Wrote: welcome,
nice data !, but only 1 parameter in this xls file can I figure out RPM in red.
are you logging metric,? where is ECT data in C" 90C ? line 9 ECT? Sorry - all values are metric. Line 8 is ECT

id need you to put each sensor name for each line, and some are trim, i see. I attached the same Excel file in an older version - can you see the sensor names in there?
yes, many DTCs are 2 or 3 driving cycles, but pendings , are limited to 1 at a time. so weak that.
the numbers matter in the XLS but no index to your list, at all, sorry.
my scan tool the PARAMS , i can log in any order or sets, so the order is never the same tool to tool , must be known first. (names)_
compression good
vacuum good, but does the vacuum read correctly when throttle gunned, (i bet it does with new cat) not melted. I do not have those numbers - what is desired when throttle gunned?
fuel pressure are ok , if you gun engine and pressures stay over 30 and up to 40. Fuel pressure was 43# when misfire was happening
if the maf reads ok, seems to me the injectors clogged from bad gas. PO said he replaced injectors - will check if old ones were reinstalled
is ECT at 180f to 195 hot? 181 to 201 F hot
if maf is ok, and the fuel pressure builds off idle (gunned) seems it does, so the injectors are packed. (make sure all 4 are noid tested and firing)

ok i just uploaded what you said is missing in books, sure store rag books sux sure, chill-tons, HAY-Wired (haynes)
sure.
but the real book is full of all DTC info... each test if fully defined, and is here.
as of today , put there in post 1, ack-faq.
here it is ( best EFI pages and engine manual) see part 1, 2,3,4 those are all DTC fully documented by suzuki then reprinted by GEO.
here:
http://ge.tt/6gvplbp2


I say clogged injectors.
pressure fuel ok, MAF not dead,
the maf works in cold start, so if good , no 02 sensor needed for cold and WOT.
if the injectors are clogged many report the MAF unplugged adds power, well sure its in limphone goes super rich and can hide 1/2 clogged injectors to a limited amount.

yes p0300 is all cyl, misfiring but will not set in one drive. but you hear it missing so... we know it is. I will try to post video of misfire for you
all spark parts new> (is see full tune up below but not plugs? gaped to 0.028" never use out of box gap it is always wrong.at 0.045" says NGK Plugs were in good condition, but I gapped all to 0.028"

or bad coil. inside distrib,
wish i could see each line 5 to 23 names? If you cannot view PID names in attached file, let me know and I will list them

if the injectors are clogged, we can prove that , with propane gas. not LIT. feed it a snort of propane gas in the intake at (IAT sensor port?) on air cleaner box. and see if it wakes up, at the BOG point, if yes, injectors are clogged. OK
http://www.fixkick.com/tools/Propane-tester1.jpg
( a normal propane nozzle, unscrewed and host attacked works same as this OTC tooL))


the MAF can be tested with a voltmeter, on the output pin easy. type maf in my fixkick, search box. super easy testing MAF Will do

Thanks for all the great info!


Attached Files
.xls   X90 OBD2 Data 10 DEC 18 old.xls (Size: 32 KB / Downloads: 5)
Reply
#4
In case you can't view the sensor data in the recently attached file...

Line 5: FUELSYS1 - Fuel System 1 (shows closed or open loop)
Line 6: FUELSYS2 - Fuel System 2 (does not exist on G16B?) {v6 or v8 , bank 2 system}
Line 7: LOAD_PCT - Engine Calculated Load Value (percentage)
Line 8: ECT - Engine Coolant Temp (celsius)
Line 9: SHRTFT1 - Short Term Fuel Trim 1 (percent)
Line 10: LONGFT1 - Long Term Fuel Trim 1 (percent)
Line 11: MAP - Manifold Absolute Pressure (kPa)
Line 12: RPM - RPM
Line 13: VSS - Vehicle Speed (kph)
Line 14: SPARKADV - Spark Advance (degrees)
Line 15: IAT - Intake Air Temp (celsius)
Line 16: MAF - Mass Air Flow (grams/sec)
Line 17: TP - Throttle Position (percent)
Line 18: 02SLOC (location of 02 sensors?)
Line 19: 02B1S1 - 02 Bank 1 Sensor 1 (volts)
Line 20: SHRTFTB1S1 - Short Term Fuel Trim Bank 1 Sensor 1 (percent)
Line 21: 02B1S2 - 02 Bank 1 Sensor 2 (volts)
Line 22: SHRTFTB1S2 - Short Term Fuel trim Bank 1 Sensor 2 (percent)
Line 23: OBDSUP (OBD requirements?)

Hope this helps!

Fabricator
Reply
#5
ECT 94C why so hot, ?201.2F is HOT, max hot thermostats are 195F, 180f is stock. so 200f is wrong or ECT is bad.
thermostat bad/wrong, radiator clogged. fan clutch dead/ or some other cooling system issues,? this is a problem but not THIS problem.
98kpa , is 1bar/100kpA is WOT, very near. so i see that. frame 16 (gunning throttle sure)
frame 16, only 1300 RPM, so that is a huge bog? super bad engine power.
vss = 0 means , car is parked, or VSS bad. moving,

spark advance , OK , 8 TO 42, In park or neutral advance is very aggressive due to no engine load. here. normal.

TPS 93% or WOT. good.
02 off line, frame 15/16. is normal, in Openloop , wot is always Open loop. and is normal

MAF shows 2 to 20, and 20 is way less that 55, but MAF is a chicken and egg thing,
( if engine bogs 50 can not be attained.) can be for engine,weak,or cat clogged, weak maf, weak fuel pressure (not you) or in limphome)

conclusions,
MAF weak.???????????????? why? , no vacuum leak can cases this unless maf not present in many induction tube. (stock induction?)
see my rules pages below.


CEL lamp off ,in all data seen in XLS?
the canada car (not factory CAMI ) but sold to citizens of this country has no CEL for misfire. (MIL dead)
proof. (silly of them to do that but they did) (hood sticker tells you if car is USA EPA or canada (oakleaf, smog car)
http://www.fixkick.com/CEL/96DTC-ECU2.jpg



list of DTCs that can cause, limphome, I and to dig this out of the 4 long chapters posted above(PDF) 10 years ago did that.
your 96 the transmission has its own DTC connector under steering column
MAF = P0102/103
IAT = P0112/113
ECT = P0117/118
TPS = P112/123
VSS1 = P0500 ( speedo vss) Vehicle Speed sensor = VSS (moving only)
(97+ and newer only do below) P07 means 4speed box.
TR = P0705 (A/T Range shifter output in conflict) (gear shiftier switch LIES)
VSS2 = P0720 ( 4sp Vss tail speed sensor dead) , moving only.
SS#1 = P0753 (shift solenoid 1 bad)
SS#2 = P0758 (shift solenoid 2 bad)
TCC = P0743 (torque converter clutch malf)

the transmission must be scanned too. if 4speed, is it?

back to maf againl.
see me hit 55 on my maf? I plotted this is Excel. then. TPS over MAF. simple but very effective. (but maf only can be tested this way with good engine good injectors and full fuel pressure)
http://www.fixkick.com/my96-16v/MAF-TPS.JPG

if the engine can not make power, the MAF will show weak even a new MAF, due to air flow IS WEAK (if fuel mix goes weak the maf will show weak)
I then took the maf off the car and used my vacuum cleaner. and got 3 volts output on my MAF, a leaf blower would do more. 4v?
due to one guys car was weak MAF but really was not. (his was fuel pressure low, or injectors clogged.)

is CAT plugged up? if vacuum looks backwards gunning throttle or bounces VACUUM is wrong and if queer odd , vacuum inversions, CAT IS melted.
but is new CAT so is not Cat.
ok so far we have these facts.
http://www.fixkick.com
Reply
#6
so you CEL lamp never glows running?
keyon glows, start engine, CEL goes out and stays out. (but in canada the CEL/,MIL lamp lies to you, just the lamp not the scans) ok?

see this. here is my 96, this and the vin tells me what that X90 had day 1, new, and for sure what transmission.
http://www.fixkick.com/specs/Body-TAGS/h...age_9.html

see the word EPA there, this tells me lots too.

the 4speed automatic (DO you have that?)
The OD lamp in 4speed car flashes if the TRANNY is sick. but will not cause the ECU go nuts , in 1996, only on 1997 up.
uses this DLC for just it ( there are 3 DLC on this car) OBD2 DLC#1 , 4speed (if fitted)#2, and under hood DLC#3 for spark and idle controls.(at right Front headlamp rear, 6 pin DLC)
this front DLC3 at RF headlamp make very sure no jumpers are inserted in this jack, (see plug there with rubber cap that is DLC)
92-96 only and only 4speed box.
http://www.fixkick.com/tranny/slush/slid...conn1w.jpg

in 1997 they deleted this jack #2 and moved TCM brain into ECU brain and called it a PCM. and now fails for smog USA if this TCM shows errors.
in1997 , tranny errors show up only in OBD2 scan tool port. and can do limphome mode just for the tranny.
http://www.fixkick.com
Reply
#7
driving cycles are not simple, like keyon , key off, key on, be nice if they had DLC jumper to do that, called, (driving cycle disabled)
but due to that , DLC are a pain in the bottom gasket.
btw, i will study your xls more completely later today.. before 6pm.

http://ge.tt/6gvplbp2

see chapter 3 part3) (down load , the view online fails for too big ) P0300 misfire, 300 means all 4 fail and all 4 random failing. (so is most time AFR RELATED) BUT THERE ARE LEAN AND RICH CODES
page 11 +
300 MEANS weak piston;rod/crank accelerations, means combustion was weak ,or spark failed, or injector failed. (in this case all 4 are weak)
seem the frame 15 engine goes lean, to me, best I can tell in, openloop.
ON THE DATA FRAME 15 , AT WOT THE O2 GOES LEAN AND THE MAF IS WEaK, CLEAN IT TEST THE MAF MORE CAREFULLY.

why is MAF weak this is the focus point.
the injectors could all 4 be clogged (1/2 way)
from bad fuel parked over a year.
the injector balance test may fail.

DTCs go offline, if fuel level is below 15% (Page 11) 11 to 14 (are p0300)
P0300 needs steady (steady TPS) to run the monitor, idle or steady cruise. the CEL then blinks on USA car, telling driver, your cat will soon burn up.even melt.
below 4000 RPM rule (300's)
causes
Huge vacuum leak or weak maf or only dirty maf.
I'd say engine is going lean. (02 off line , I cant see it go lean thanks to tools OBD2,silliness here) My scan tool fancy I can force or even loop on 02 readings live. and 2d scope view them)
the injectors weak? theory,/? one can add propane gas to IAT port. to see of bog or misfire ends.
P300 per page 11,. has 2 times rule in this DTC,
even bad fuel can do this. super easy,
page 11 list them all.
bad fuel
weak maf
vacuum leaks.
injectors 1 ,2,3,4 all weak, (partically clogged, due to bad fuel)
lean or too rich misfire.
and spark must be good, (got new plugs? set to 0.028 inches, J plugs only no surface fire plugs allowed on this weak spark system)
fuel filter 22 years old, and 90% packed up? if fuel pressure drops at frame 15, BINGO,

DTC's set for 2 ignition cylces (so 1 run will no set many DTCs) in general, one has to read all 4 parts, (PDF) to see all rules, I just OCR mine to find "cycle"
they clear with 2 to 40 driving cycles.
its not low fuel pressure. (so we skip this and is super common)


no P0171 or 172 trim errors (part3, page6)
I dont see fuel trim landing on 43% or greater long-term fuel trim or over 20% short term.
does you scan tool have, O2 sensor graph viewer? (this loops the scans on B1S1. bank 1, sensor 1 front, and see if the sensors goes to 0v,? lean? stuck lean.
if yes, MAF is week or injectors clogged
http://www.fixkick.com
Reply
#8
the tricky part here is car is not on the road, only load testing works, fully loaded car or up hill flogged (but fails parked, so that too is ok.)
so test the car parked, and gun engine hit, and for 3 key on cycles, hot. repeat 2 or 3 times see if DTC set !!!

to see if MAF works, but do clean it first.
if still fails after clean maf
test injectors, next. or pro clean them . like seen , reverse flowed, untrasonic cleaned.
https://www.witchhunter.com/


i just added this, and applies to P0300, 301 upto P0304 ( 1,2,3,4 code means only this cylinder fails.
so put more gas in take, over 15%
and run the test 2 times, hot engine gun throttle hard, parked, and see if P03xx codes POP, or P0171 or PO172 (rich lean pop)
even flog the throttle from 2000 to 4000 RPM (or if bogs still try)
or try to hold throttle steady at 3000 RPM or 4000 for say 10 seconds, see of DTC's POP, the 300s series only POP for steady cruise,

[Image: 3_13_12_18_8_35_40.jpeg]

bad fuel
bad maf (dirty
vacuum leaks huge. (super huge, that is do not believe)
dirty injectors or filter.
I assume spark plugs new. at the tips white now or jet black carboned.?

even this cheap HARBOR FRIGHT(SIC) tool can loop scan the 02 front " Graph live data onscreen" feature set is very good to have. like this.
[Image: O2b1s1.jpg]


great 02 demo here, even many cheap tools can do this even $50 (ask) ignore bank 2 comments and 2rear sensor but do listen to all S1 comments for sure
idle, cruise, gunned throttle and fuel cut modes(deceleration) lazy 02 or dead or stuck lean are all things to check and graphing 02 is the only way to do this.
https://www.youtube.com/watch?v=jRa752CeNvg
http://www.fixkick.com
Reply
#9
IMO the best tool is the USB/WIFI/BT dongle tool (wifi is truly the best one for max wireless range.) USB wired is the most cheap but not weak at all.
that runs on any PC, any cell phone. (or even MAC or linux)
that means you can run 100s of software apps, to get the data you want, like looping on O2 and graph scanning just it.

https://www.scantool.net/scan-tools/


the hand held tools can be very poor to very good.
see good here.
innova 3160 is my fav. but is not dirt cheap. hand held and smart are not cheap.
http://www.fixkick.com
Reply
#10
(12-13-2018, 10:49 PM)fixkick Wrote: ECT 94C why so hot, ?201.2F is HOT, max hot thermostats are 195F, 180f is stock. so 200f is wrong or ECT is bad.
thermostat bad/wrong, radiator clogged. fan clutch dead/ or some other cooling system issues,? this is a problem but not THIS problem.

Will check t-stat and associated cooling system as it seems to take awhile to warm up too...

98kpa , is 1bar/100kpA is WOT, very near. so i see that. frame 16 (gunning throttle sure)
frame 16, only 1300 RPM, so that is a huge bog? super bad engine power. Frames 15 & 16 show data when misfire is taking place, hence 93.3 TPS to make it happen
vss = 0 means , car is parked, or VSS bad. moving, Yes, car standing still

spark advance , OK , 8 TO 42, In park or neutral advance is very aggressive due to no engine load. here. normal.

TPS 93% or WOT. good.
02 off line, frame 15/16. is normal, in Openloop , wot is always Open loop. and is normal OK

MAF shows 2 to 20, and 20 is way less that 55, but MAF is a chicken and egg thing,
( if engine bogs 50 can not be attained.) can be for engine,weak,or cat clogged, weak maf, weak fuel pressure (not you) or in limphome)

conclusions,
MAF weak.???????????????? why? , no vacuum leak can cases this unless maf not present in many induction tube. (stock induction?)
see my rules pages below. PO said known good MAF was swapped in while troubleshooting, made no difference - old MAF reinstalled


CEL lamp off ,in all data seen in XLS? CEL works key on and goes off after start
the canada car (not factory CAMI ) but sold to citizens of this country has no CEL for misfire. (MIL dead)
proof. (silly of them to do that but they did) (hood sticker tells you if car is USA EPA or canada (oakleaf, smog car)
http://www.fixkick.com/CEL/96DTC-ECU2.jpg Will check sticker for that info



list of DTCs that can cause, limphome, I and to dig this out of the 4 long chapters posted above(PDF) 10 years ago did that.
your 96 the transmission has its own DTC connector under steering column
MAF = P0102/103
IAT = P0112/113
ECT = P0117/118
TPS = P112/123
VSS1 = P0500 ( speedo vss) Vehicle Speed sensor = VSS (moving only)
(97+ and newer only do below) P07 means 4speed box.
TR = P0705 (A/T Range shifter output in conflict) (gear shiftier switch LIES)
VSS2 = P0720 ( 4sp Vss tail speed sensor dead) , moving only.
SS#1 = P0753 (shift solenoid 1 bad)
SS#2 = P0758 (shift solenoid 2 bad)
TCC = P0743 (torque converter clutch malf)

the transmission must be scanned too. if 4speed, is it? Trans is 5-speed(?) manual

back to maf againl.
see me hit 55 on my maf? I plotted this is Excel. then. TPS over MAF. simple but very effective. (but maf only can be tested this way with good engine good injectors and full fuel pressure)
http://www.fixkick.com/my96-16v/MAF-TPS.JPG

if the engine can not make power, the MAF will show weak even a new MAF, due to air flow IS WEAK (if fuel mix goes weak the maf will show weak)
I then took the maf off the car and used my vacuum cleaner. and got 3 volts output on my MAF, a leaf blower would do more. 4v?
due to one guys car was weak MAF but really was not. (his was fuel pressure low, or injectors clogged.)

is CAT plugged up? if vacuum looks backwards gunning throttle or bounces VACUUM is wrong and if queer odd , vacuum inversions, CAT IS melted.
but is new CAT so is not Cat.
ok so far we have these facts.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)