Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Idle switch question
12-13-2018, 04:13 AM
Post: #1
Idle switch question
Hey everyone, I'm after a bit of help with my Suzuki escudo. Symptoms are:
I'm only getting 320km from a full tank of gas.
Slight bog on acceleration (hot and cold), but only when first pressing accelerator pedal. Revs and accelerates great right up to 100kph otherwise.
Low rpm at idle, engine shakes a little and seems to misfire at idle.

I have tested and calibrated the tps according to fix kick instructions. Everything checks out right apart from the idle switch goes from 0v at idle to 11.7v off idle. Shouldn't it be 5v? Is this a clue to some of the symptoms I'm experiencing?

I've given it a good tune up. New HV leads, timing belt, spark plugs, dizzy cap, checked and repaired sheared crankshaft keyway, set ignition timing, checked compression (155 all cylinders), checked fuel pressure (36psi).

Any advice would be awesome thanks!
Brendon

1992 Suzuki Escudo G16A 16v LWB 4speed auto[font=Courier][size=small][/size][/font]
Find all posts by this user
Quote this message in a reply
12-13-2018, 04:40 AM (This post was last modified: 12-13-2018 04:49 AM by fixkick.)
Post: #2
RE: Idle switch question
hello and welcome
what year is car?
first what is in your Escudo, what engine, what trans.?
G16? engine? susuki use lots of engines world wide. yes, is it 8valve or 16valve if 4 cylinder, 1.6L engine SOHC. (single cam)
the Escudo came in Sq416 and SW420 versions, 4 cyclinder 1.6 and 2.0 liter engines up to 2003 and 1 diesel you dont have.
and radical different EFI too, ever seen a JDM version of a car and wow (some are smog free, no CAT, no EGR, no 02 sensors)
10 gallon tank? (or in liters what?) 9 L/100km is normal. (highway miles not city)
cold bog is serious. but is not really a full on bog but is just small hesitation.?
how low RPM , or tacho missing in dash?
your fire wall next to battery , has Huge TAG, that shows what car you really have, for sure this. see 24 there. what is your 24, means country code)?
[Image: Jap-E24-1994plate.jpg]



(12-13-2018 04:13 AM)eatthebiscuits Wrote:  Hey everyone, I'm after a bit of help with my Suzuki escudo. Symptoms are:
I'm only getting 320km from a full tank of gas. 320km is 200miles, 10 gallons is 20MPG, and is 6 low about. but the liters used Id need to know.
Slight bog on acceleration (hot and cold), but only when first pressing accelerator pedal. (so WOT wide open throttle has full power?)
Revs and accelerates great right up to 100kph otherwise. ok just hesitation,
Low rpm at idle, engine shakes a little and seems to misfire at idle. hot idle is 800RPM , how low is low? RPM=

I have tested and calibrated the tps according to fix kick instructions.
Everything checks out right apart from the idle switch goes from 0v at idle to 11.7v off idle.
Shouldn't it be 5v? (but only on our cars, in USA, are 5v) no engine stated.
Is this a clue to some of the symptoms I'm experiencing?

I've given it a good tune up. New HV leads, timing belt, spark plugs, dizzy cap, checked and repaired sheared crankshaft keyway, set ignition timing, checked compression (155 all cylinders), checked fuel pressure (36psi). (at idle?)

Any advice would be awesome thanks!
Brendon

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
12-13-2018, 05:18 AM (This post was last modified: 12-13-2018 05:22 AM by fixkick.)
Post: #3
RE: Idle switch question
lots of variances world wide.
where is car located (country), or what plant built it?

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
12-13-2018, 06:39 AM
Post: #4
RE: Idle switch question
(12-13-2018 04:13 AM)eatthebiscuits Wrote:  Hey everyone, I'm after a bit of help with my Suzuki escudo. Symptoms are:
I'm only getting 320km from a full tank of gas.
Slight bog on acceleration (hot and cold), but only when first pressing accelerator pedal. Revs and accelerates great right up to 100kph otherwise.
Low rpm at idle, engine shakes a little and seems to misfire at idle.

I have tested and calibrated the tps according to fix kick instructions. Everything checks out right apart from the idle switch goes from 0v at idle to 11.7v off idle. Shouldn't it be 5v? Is this a clue to some of the symptoms I'm experiencing?

I've given it a good tune up. New HV leads, timing belt, spark plugs, dizzy cap, checked and repaired sheared crankshaft keyway, set ignition timing, checked compression (155 all cylinders), checked fuel pressure (36psi).

Any advice would be awesome thanks!
Brendon

Hey thanks! It's a 1992 1.6L 16v Mpi SOHC Sq416, 4 door with the 4 speed auto transmission
Fuel tank has 55L capacity.
Yes it has full power at WOT. Just a hesitation when taking off.
Tacho on dash not working, but just feels low with the shaking/misfire.
Will check country code when I get home tonight.
Yes fuel pressure was 36psi at idle.
Would a vacuum leak cause this hesitation and higher fuel consumption? It does have a 2in suspension lift and 30in tyres.

1992 Suzuki Escudo G16A 16v LWB 4speed auto[font=Courier][size=small][/size][/font]
Find all posts by this user
Quote this message in a reply
12-13-2018, 06:50 AM
Post: #5
RE: Idle switch question
(12-13-2018 05:18 AM)fixkick Wrote:  lots of variances world wide.
where is car located (country), or what plant built it?

New Zealand

1992 Suzuki Escudo G16A 16v LWB 4speed auto[font=Courier][size=small][/size][/font]
Find all posts by this user
Quote this message in a reply
12-13-2018, 08:58 AM
Post: #6
RE: Idle switch question
(12-13-2018 06:39 AM)eatthebiscuits Wrote:  
(12-13-2018 04:13 AM)eatthebiscuits Wrote:  Hey everyone, I'm after a bit of help with my Suzuki escudo. Symptoms are:
I'm only getting 320km from a full tank of gas.
Slight bog on acceleration (hot and cold), but only when first pressing accelerator pedal. Revs and accelerates great right up to 100kph otherwise.
Low rpm at idle, engine shakes a little and seems to misfire at idle.

I have tested and calibrated the tps according to fix kick instructions. Everything checks out right apart from the idle switch goes from 0v at idle to 11.7v off idle. Shouldn't it be 5v? Is this a clue to some of the symptoms I'm experiencing?

I've given it a good tune up. New HV leads, timing belt, spark plugs, dizzy cap, checked and repaired sheared crankshaft keyway, set ignition timing, checked compression (155 all cylinders), checked fuel pressure (36psi).

Any advice would be awesome thanks!
Brendon'
welcome you are from down under ,I was there in 1972, joint navy exercises. nice place lots of sheep! No hamburgers then... eegads/...

Hey thanks! It's a 1992 1.6L 16v Mpi SOHC Sq416, 4 door with the 4 speed auto transmission
Fuel tank has 55L capacity.
Yes it has full power at WOT. Just a hesitation when taking off.
Tacho on dash not working, but just feels low with the shaking/misfire. EGR main valve leaking , is very common cause of idle low and shacking engine,
Will check country code when I get home tonight.
Yes fuel pressure was 36psi at idle.
Would a vacuum leak cause this hesitation and higher fuel consumption? It does have a 2in suspension lift and 30in tyres.

yes 16v engine is MPI, lots of ways fail.
but even leaking injectors but they are not clogged.
the the main pipes top side huge, go from air cleaner MAF on the cleaner box back to the throttle body can have no AIR leaks, in that path.
the MAF should be cleaned now with cleaner and no closer than 8 inches (200mm) from the maf elements, it is fragile
clean spray it , wait one minute and repeat 3 times, the delay softens the gum for the next hit.

a dirty maf will act just like air leaks. in that huge pipe.
as will plenum leaks behind the throttle body.
but mostly at light throttle usage.
the main pipe has big rubber ring seals that can get pinched funny and leak, make sure the main tube has no cracks, in it, for sure near mounts

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
12-13-2018, 09:05 AM
Post: #7
RE: Idle switch question
bet ,country code 24 i best, pure luck me guessing.
many of these cars are in South AMerica, I will be there soon, on vacation.
I have no schematics of your ECU up here.
so no idea how your idle switch works,
does this car have MAF cold air kit on it, which loves to make MAF bounce and die? it must not be allowed to do that.
and the MAF has funny grill in front that must not be removed
sorry if your TB and MAF is not like ours, id have to see photo of top of engine to go, ah that manifold that maf and that TB?
some cars down under have totally different TB some more integrated.
like our J20 has now(engine).

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
12-13-2018, 09:15 AM
Post: #8
RE: Idle switch question
155 compression is tad low ours does 190 (new )
not sure why, (keyway off) belt off one tooth cam.
are you at sealevel, ?
my 97/97 16v did this at 100,ooo miles odometer.
My 1996 Geo Tracker 1.6Liter 16valve. , pulls 183-185 PSI on all 4 cylinders. (warm ) The 16v is 195 PSI. Seen in FSM chapter 6-6. HOT SPEC> cold is less, a tad.

was in town there ,volcanic center called Rotorua . (amazing place ever, houses with steam pipe running from dirt below home to roof in many rooms oddly placed to vent he volcanic steam,
wild and fun place.
The coolest country ive ever seen there.
whole pacific.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
12-13-2018, 09:57 AM
Post: #9
RE: Idle switch question
(12-13-2018 09:15 AM)fixkick Wrote:  155 compression is tad low ours does 190 (new )
not sure why, (keyway off) belt off one tooth cam.
are you at sealevel, ?
my 97/97 16v did this at 100,ooo miles odometer.
My 1996 Geo Tracker 1.6Liter 16valve. , pulls 183-185 PSI on all 4 cylinders. (warm ) The 16v is 195 PSI. Seen in FSM chapter 6-6. HOT SPEC> cold is less, a tad.

was in town there ,volcanic center called Rotorua . (amazing place ever, houses with steam pipe running from dirt below home to roof in many rooms oddly placed to vent he volcanic steam,
wild and fun place.
The coolest country ive ever seen there.
whole pacific.

Yep, living in a pretty amazing place down here in little old New Zealand. I'm in the able Tasman area, just beautiful, and great fishing.
Actually, the 155 compression readings were before I repaired the slipped crank pulley and keyway. I haven't done another test yet. I need to grab myself a vacuum gauge and check that's within spec too. I'm starting an automotive apprenticeship in January so will be buying myself some tools for Christmas I reckon. I'll take a photo of the engine bay for you. The isc setup looks a tad different to photos I've seen on this site. Such a wealth of information on here. THANKS!

1992 Suzuki Escudo G16A 16v LWB 4speed auto[font=Courier][size=small][/size][/font]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)