Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low R.P.M.
06-06-2018, 05:12 AM (This post was last modified: 06-06-2018 05:41 AM by mateito505.)
Post: #1
Low R.P.M.
Hello everyone,

I have a Chevrolet Vitara 2007 (Colombia - Latin America retail), in essential it is a Suzuki Sidekick. It has a G16B engine (1.6L@16V). I'm writing this post because I'm having some issues with my car when I turn on headlights or defrost. Sometimes when I did that the ECU can't regulate the R.P.M to ~800 and the revolutions fluctuate between 400 or 500 while the car is stopped (idle), other times the ECU can regulate the R.P.M without problem. I'm going crazy with this problem. I already clean and check the TB, I did special emphasis in the ISC valve. (This problem happen regularly)

Another issue with my car (probably it is related to the first problem) is when I am driving the car in the highway during 20 minutes in constant speed and when I have to stop because of a traffic light or traffic jam in the city... in that moment when the car is stopped (idle) or I'm not touching the accelerator and the car is in neutral gear (ISC is working), the R.P.M fluctuates between 400 and 500 again... And sometimes the car turn off abruptly. When it happens I turn off and turn on again the car and it goes to work properly again. (This problem happen 2 or 3 times per month)

What can I do to fix those problems? (FPR realted problem?, TPS calibration?, anything else?) Someone tell me about a bad diode in the headlights circuit but I haven't idea...

Thanks in advance.

English is not my mother tongue; please excuse any errors on my part."


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
06-06-2018, 05:49 AM (This post was last modified: 06-06-2018 05:52 AM by fixkick.)
Post: #2
RE: Low R.P.M.
(06-06-2018 05:12 AM)mateito505 Wrote:  Hello everyone,

I have a Chevrolet Vitara 2007 (Colombia - Latin America retail), in essential it is a Suzuki Sidekick.
It has a G16B engine (1.6L@16V). 4wdor 2wd, 2doors or 4, what transmission, auto or stick.?


I'm writing this post because I'm having some issues with my car when I turn on headlights or defrost.\
Sometimes when I did that the ECU can't regulate the R.P.M to ~800 and the revolutions fluctuate between 400 or 500 while the car is stopped (idle), other times the ECU can regulate the R.P.M without problem. I'm going crazy with this problem.
I already clean and check the TB, I did special emphasis in the ISC valve. (This problem happen regularly)
The ISC is offline ,or jammed.
The purpose of the ISC (its a slave of the ECU , 100% so) is to hold hot idle at 800rpm, and in gear, if automatic
the worst case is with automatic, in neutral shift to drive and a huge load goes on to the engine, (via the TC clutch drag is HUGE)

The first step you skipped, scanning the ECU , why skip step 1 on all cars, with EFI>?
if there ECU shows P0xxx errors, DTC errors, know and learn that some are limphome mode, and there are no idle controls in limphome mode
so that is why you always must scan any cars engine first, to see whats wrong, first. guessing is impossible here, see why?
P0400 EGR failure? oops.


Another issue with my car (probably it is related to the first problem (IT IS)) is when I am driving the car in the highway during 20 minutes in constant speed and when I have to stop because of a traffic light or traffic jam in the city... in that moment when the car is stopped (idle) or I'm not touching the accelerator and the car is in neutral gear (ISC is working), (are you really in Neutral driving at a light? stopped? why? never seen anyone do that. (but saves fuel it does)

the R.P.M fluctuates between 400 and 500 again...
also EGR stuck open causes 400rpm this is the all time #1 cause. clean the EGR main or replace it.

And sometimes the car turn off abruptly. the word is STALLS, engine stalls.
and 99% of time the EGR main is this cause.

When it happens I turn off and turn on again the car and it goes to work properly again. (This problem happen 2 or 3 times per month)

What can I do to fix those problems? (FPR related problem?, TPS calibration? (no such thing in 2007), anything else?)

Someone tell me about a bad diode in the headlights circuit. but I haven't idea... your friend is off base, sorry, there is no diode in any 2007 car, his was an 1988, a whole other car and electrics. what he meant to say is 1989 car has diode bock on the ECU that is a (wired OR logic gate)
that raises idle to 1000rpm head lamps on, this diode ended 29 long years ago.


Thanks in advance.


the ISC also prevents all stalls
it opens the ISC wide open and no stalls possible. EXCEPT (there are other reasons, but...)
But if the EGR sticks open it stalls or runs 400 rpm and shakes like wet dog, misfiring like MAD, you can even see the engine shake hard.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
06-06-2018, 08:16 AM
Post: #3
RE: Low R.P.M.
(06-06-2018 05:49 AM)fixkick Wrote:  
(06-06-2018 05:12 AM)mateito505 Wrote:  Hello everyone,

I have a Chevrolet Vitara 2007 (Colombia - Latin America retail), in essential it is a Suzuki Sidekick.
It has a G16B engine (1.6L@16V). 4wdor 2wd, 2doors or 4, what transmission, auto or stick.?


I'm writing this post because I'm having some issues with my car when I turn on headlights or defrost.\
Sometimes when I did that the ECU can't regulate the R.P.M to ~800 and the revolutions fluctuate between 400 or 500 while the car is stopped (idle), other times the ECU can regulate the R.P.M without problem. I'm going crazy with this problem.
I already clean and check the TB, I did special emphasis in the ISC valve. (This problem happen regularly)
The ISC is offline ,or jammed.
The purpose of the ISC (its a slave of the ECU , 100% so) is to hold hot idle at 800rpm, and in gear, if automatic
the worst case is with automatic, in neutral shift to drive and a huge load goes on to the engine, (via the TC clutch drag is HUGE)

The first step you skipped, scanning the ECU , why skip step 1 on all cars, with EFI>?
if there ECU shows P0xxx errors, DTC errors, know and learn that some are limphome mode, and there are no idle controls in limphome mode
so that is why you always must scan any cars engine first, to see whats wrong, first. guessing is impossible here, see why?
P0400 EGR failure? oops.


Another issue with my car (probably it is related to the first problem (IT IS)) is when I am driving the car in the highway during 20 minutes in constant speed and when I have to stop because of a traffic light or traffic jam in the city... in that moment when the car is stopped (idle) or I'm not touching the accelerator and the car is in neutral gear (ISC is working), (are you really in Neutral driving at a light? stopped? why? never seen anyone do that. (but saves fuel it does)

the R.P.M fluctuates between 400 and 500 again...
also EGR stuck open causes 400rpm this is the all time #1 cause. clean the EGR main or replace it.

And sometimes the car turn off abruptly. the word is STALLS, engine stalls.
and 99% of time the EGR main is this cause.

When it happens I turn off and turn on again the car and it goes to work properly again. (This problem happen 2 or 3 times per month)

What can I do to fix those problems? (FPR related problem?, TPS calibration? (no such thing in 2007), anything else?)

Someone tell me about a bad diode in the headlights circuit. but I haven't idea... your friend is off base, sorry, there is no diode in any 2007 car, his was an 1988, a whole other car and electrics. what he meant to say is 1989 car has diode bock on the ECU that is a (wired OR logic gate)
that raises idle to 1000rpm head lamps on, this diode ended 29 long years ago.


Thanks in advance.


the ISC also prevents all stalls
it opens the ISC wide open and no stalls possible. EXCEPT (there are other reasons, but...)
But if the EGR sticks open it stalls or runs 400 rpm and shakes like wet dog, misfiring like MAD, you can even see the engine shake hard.

Sorry about car's information. It is a 2-door and 4wd with manual transmission.

Sorry again, but I don't have an ECU scanner at this moment, trust me it would have been my first step.
Although I have a question at this point. If I had a problem like P0400 EGR Failure.. Should be the check engine light on or not necessary?

On other hand, What do you mean when you said "The ISC is jammed"? What can I do to fix that?

What is your recommendation to clean the EGR main?

Thank you so much for your time and recommendations.

Mateo
Find all posts by this user
Quote this message in a reply
06-06-2018, 09:59 AM
Post: #4
RE: Low R.P.M.
all i know is this?
Colombia
are you there?
cars made for USA and canada and the rest of the world are not the same.
some countries don't turn on the CEL lamp unless it's more serious, like in CaNADA,

but our cars, every single one 1996 to NOW, all glow the CEL (USA ) For P400 errors , on some other codes, if it fails the lamp is dead until. 3 key on trips.
that is why only a scan tool work, here, ours is OBD2 tool, costing $15 to $200 depending on features.



the scan tool has button called pending codes, and never lies to you here,
for example it will hold a pending for 3 keyon trips then if failed , now, CEL glows
now you know just how useless any CEL lamp is , here, 1996_
in 1995 and back code 51 EGR always turns on the CEL, but that was long long time ago


each factory makes cars for the world over, called markets, if yours was marketed to other countries, what trips the CEL is anyones guess,
to me the lamp is only useful if its one, if off , it means zero to me. totally.

Here in our town any shop will scan it for free, as GOOD WILL.

why not remove the EGR main and clean it, is not your EGR electric motor, all ours are 1999 + I think.
It can be cleaned, for sure,

the engine is at 400 RPM
for gross misfire.
that is EGR stuck open
bad spark, again the scan tool tell you P03xx codes for all types of misfires.
it can be going lean and misfiring (it would bog and die)
or goes super rich and misfires turning the spark tips black
does this engine have 2 cop coils on top 2 coils and 4 HV wires sets? if yes, then the boots on those coils are shorting, P0300 etc.
or clogged injectors.

scanning it , is first, and push the pending button or all bets off. 3 failure rules fools every one,
the FSM covers this , lists ever single DTC error and how many it take to set CEL on,. factory service manual.

good luck.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)