Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
96 pontiac sunrunner bad idle miss bog
03-09-2018, 09:00 AM
Post: #1
96 pontiac sunrunner bad idle miss bog
Were currently working on a 96 sunrunner/tracker 16v mpi. Starts great idles ok for a second then drops right off and starts loping and sputtering. Driveablity it is ok with little throttle once it gets past about .25 it starts missing and bogging.
It has new timing belt.
New distributer
Checked the tps ohms fine
New maf
New plugs.
Egr port is blocked off at manifold. We made a custom one.
What could it be?
Any help would be great.
Thanks
Dylan
Find all posts by this user
Quote this message in a reply
03-09-2018, 10:10 AM
Post: #2
RE: 96 pontiac sunrunner bad idle miss bog
new mag spark wires
plugs gapped at .028" not .045 out of box.
so runs ok hot.
thermostat ok, 180f or more

what is is .25? time . RPM? speed?

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
03-09-2018, 10:58 AM
Post: #3
RE: 96 pontiac sunrunner bad idle miss bog
(03-09-2018 10:10 AM)fixkick Wrote:  new mag spark wires
plugs gapped at .028" not .045 out of box.
so runs ok hot.
thermostat ok, 180f or more

what is is .25? time . RPM? speed?

I meant over .25 throttle it starts to die.
Doesnt run good ever.
Dont know about thermostat but it doesn't run good ever.
Find all posts by this user
Quote this message in a reply
03-10-2018, 04:40 AM
Post: #4
RE: 96 pontiac sunrunner bad idle miss bog
You there jerry?
Find all posts by this user
Quote this message in a reply
03-12-2018, 10:52 AM
Post: #5
RE: 96 pontiac sunrunner bad idle miss bog
Help anyone?
Find all posts by this user
Quote this message in a reply
03-12-2018, 11:08 AM (This post was last modified: 03-12-2018 11:10 AM by fixkick.)
Post: #6
RE: 96 pontiac sunrunner bad idle miss bog
sorry taking nap..... lol
, fuel pressure tests?

spark good. engine good
fuel pressure wrong.
on this car pump pressure RISES as you increase throttle. see spec here

http://www.fixkick.com/INJECTORS/PUMP/16...ess95W.jpg

the key on not started pressure is very very important and is 36min, to 43. if not no power off idle, possible

thanks .25 quarter throttle sorry me head in can.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
03-12-2018, 12:06 PM
Post: #7
RE: 96 pontiac sunrunner bad idle miss bog
I'm going to check pressure this week. Its a new pump and filter inline. Suppose to be around 70psi pump. Just a universal efi one.
Find all posts by this user
Quote this message in a reply
03-12-2018, 11:24 PM (This post was last modified: 03-12-2018 11:24 PM by fixkick.)
Post: #8
RE: 96 pontiac sunrunner bad idle miss bog
" Its a new pump and filter inline. "
are you saying car is not stock now? please do tell all thing , related to EFI and smog not stock , thanks. (we are blind here and can not see your car)
or does that mean, new inside tank pump was installed and new inline filter,....(or about top be, not was)
does that mean the factory filter banjo is now missing the test port?

external;?
yes, are tricky, getting it to self prime is not easy.

many try and fail, here is my page just for this , method'

http://www.fixkick.com/INJECTORS/PUMP/cu...mp101.html

see the last bullet line there, see that deal if the pump is to powerful it overloads that tiny FPR. (one guy used huge lincoln continental pump)

it looks easy until you learn what and external pump can and can not do.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
03-13-2018, 01:01 AM
Post: #9
RE: 96 pontiac sunrunner bad idle miss bog
(03-12-2018 11:24 PM)fixkick Wrote:  " Its a new pump and filter inline. "
are you saying car is not stock now? please do tell all thing , related to EFI and smog not stock , thanks. (we are blind here and can not see your car)
or does that mean, new inside tank pump was installed and new inline filter,....(or about top be, not was)
does that mean the factory filter banjo is now missing the test port?

external;?
yes, are tricky, getting it to self prime is not easy.

many try and fail, here is my page just for this , method'

http://www.fixkick.com/INJECTORS/PUMP/cu...mp101.html

see the last bullet line there, see that deal if the pump is to powerful it overloads that tiny FPR. (one guy used huge lincoln continental pump)

it looks easy until you learn what and external pump can and can not do.

ok it has been running this tank and pump and filter set up pretty much the whole life that we have had it. its a marine tank behind the back seat with a inline electric fuel pump and filter in line as well. it was running great before. now its not.
Find all posts by this user
Quote this message in a reply
03-13-2018, 02:15 AM
Post: #10
RE: 96 pontiac sunrunner bad idle miss bog
sorry i cant see your car, not now ,
I can only fix stock cars, modified is engineering work. (race car stuff and and endless topic, and vast issues)
ok it ran ok before, sure.
got it.
but what are the 4 pressures tests, done correctly.

I do this, using the correct way, at the fuel rail pressure, using he $10 adaptor seen on my 16v pump page. best of the best this, so you can do injector leak down tests and not go mad.
or now we know, the stock banjo's are gone and with hit the test port, so use at TEE fitting.
there is NO OTHER WAY to test pressure,
the FPR love to fail now, after 22years, vast posts online now, for FPR dead, even the vacuum port leaks fuel, yup dead.
the tests are: (not shunt shunt test is 60psi not 30 ever. at least 60 sure 70 is ok)
1: key on , no start , pressure.
2: idle pressure.
3: throttle gunned hard pressure.(rises by 6psi , if not there will be no power from engine, no 95HP possible)

if not in spec the ECU will never ever inject correctly,. how could it , The ECU cant see pressure (likenew cars can), and that is #1 issues on all EFI made, pressure must be in spec.

id do not know your driving symptoms.
1: misfiring?
2: bogging.
3: hot and cold engine or just one. or both.
4: hot idle at 800 rpm?
5: fails at idle only or only accelerating or only on hills or only flat easy cruise at say 45mph. ? or all modes fail? hot and cold>????
6: water temps good 180+f hot, not 150 not 160 ever, are not good.
7:engine shakes hard at idle. (misfiring)
8: spark plugs fouled. black.
9: engine floods.? wet spark plug tips any of the 4, (injector failures)
10: engine compression ok WOT. 180psi

The scan tools works here, in usa, for 1996,up, is yours car using OBD2 ECU, the 16pin DLC connector above right shin bone is it, 16 D-shell shaped, female pins>?
some canada cars only run OBD2 in 1998, by law there.
and makes diagnoses far more easy if it is OBD2. for sure. scanning it, for DTC errors.

Ive no problems at all with non stock tanks or pumps,(i know how to do it correctly but others systems are totally infinite ways)
what matters only are the pressure tests all 3 and shut.

i even have a portable fuel pressure sender so i can test on hills at full 95HP output, finds the hard nut cases, under full load. most time not ever needed, but I can do it.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)