Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
02-06-2018, 04:17 AM (This post was last modified: 02-06-2018 04:19 AM by Shaarc5.)
Post: #1
Question 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
I have got a 89 suzuki sidekick with a crank but no start condition. I can’t figure out what the issue is, any help and advice on what to do next. Thanks for looking and any ideas you guys have.

What I’ve done trying to diagnose the problem and info on it.

1. Has spark on all plugs- good size but orange??
2. Coil has the same looking spark coming out of it- orange good size
3. Has good compression. 180-200 all cylinders
4. All fuses are good, all grounds are good/cleaned.
5. Checked for codes, got 12-12-12 good
6. Checked timing belt and dizzy, dead on. My cam can only install one way, cam titty 12 o clock, crank tdc #1

Other checks I’ve done.
1. Checked coil primary- 1.5 ohms about. Secondary about 12k ohms. Good
2. Checked signal generator resistance inside dizzy- 130-190 ohms. Good
3. Checked for play in dizzy, none.
4. Checked the vr gap inside dizzy, .008-.016. good
5. Checked each plug wires resistance about 5k per ft. Good
6. Checked injector pulse while cranking. Good
7. Unplugged injector, made sure plugs were still clean and not flooded. Sprayed starting fluid while cranking. No start.
8. Tested/adjusted the tps sensor, 30 ohms at idle and about 1.v good
9. Went through everthing again, timing, fuses, grounds. Visually checking wires, connections anything I can see. I’m lost and confused please help!

Questions.
1. What could cause a weak orange looking spark?
2. I read while cranking, my cluster rpm is supposed to rise to 400rpm, I’m only seeing it move to maybe 100 rpm-150rpm. Does this mean anything?
3. What else can I check?
Find all posts by this user
Quote this message in a reply
02-06-2018, 05:00 AM (This post was last modified: 02-06-2018 05:02 AM by fixkick.)
Post: #2
RE: 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
just with steps 1 to 4, the engine will run on test fuel spray.
keep in mind the ECU does not create spark nor control it
but the ECU will cut fuel if it thinks (tacho)line is dead, (measured it is full time)

the compression is ok. in fact super good,. most do 155 cold. sea leave 8v.
firing order wrong 1,3,4,2
front plug is #1
the problem here is the 8v and 16 turn rotor opposite, and many books (vast) show the wrong order, thinking they are same (not)
the 8v turns CW. you can watch it to prove that. so the wires a layed down CW not CCW.
use a timing light,? yet? cranked?

RPM is OK.
orange can mean the rotor is firing between cap terminals timed wrong.(grossly off)

the engine runs with no fuel in the tank, (spray started) and can be kept going doing that.
this is like goal 1, doing that .
after that we work injections. last.


http://www.fixkick.com/IGN_timing/89-timing.html

even a timing light works cranking any dead engine, a magical $20 tool....

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
02-07-2018, 12:25 PM (This post was last modified: 02-07-2018 12:30 PM by Shaarc5.)
Post: #3
RE: 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
Thanks for the reply. I went through what you mentioned and everything checks out, except when I hooked up my timing light. Here’s some more info and stuff I’ve tryed.

I checked the brwn/white wire from ignition coil to the noise suppressor, continuity was good. Checked brown wire from noise suppressor to the ecm, which turns to red/blue wire right before ecm. Also checked brown wire from noise suppressor to cluster, all good.

How can I test the noise suppressor?

More stuff I’ve tried.
1. I took the o2 sensor out at the manifold, no start.
2. Hooked up my timing light while cranking. Im not seeing the timing light flash while cranking. What does this mean?

Stuff I’ve noticed today. Rpm cluster doesn’t move more than half the time I’ve been cranking on it. I see the rpm bounce up to 100 150 right as I Let off cranking the motor over. Notice that I’m getting a little combustion/ flame out of the throttle body, as that rpm jump happens. Almost try’s to start but won’t. Not flooding as I’ve unhooked fuel supply and tryed starting fluid. I keep an eye on plugs not getting fould and still have same spark.
Find all posts by this user
Quote this message in a reply
02-07-2018, 09:08 PM
Post: #4
RE: 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
that wire only halts fuel. the brown, tachometer wires.
the suppressor never fails, sure falls off , lost but not fail.
did you buy a dead car, or it just happened one morning , dead? is there an odd story? leading up to failure?

if the tachometer works cranked over then its ok, show 100 rpm (tinydeflection) 4wd cars have tach, in most cases.
that tachomovent tells me the ECU if pulsing the coil primary of the coil.
ok spark is dead
do you know the classic old test for spark. (wires _+ spark plugs)
using test spark plug, (and a wire if needed)
for sure test spark at the coil on the fire wall first.
spark begins there,
if coil has spark but all 4 , or many spark plugs are dead, the distributor is timed wrong. gross or the cam belt slipped. but compression is super good. so, cam is ok. mostly

The distributor on this car makes all spark, (and coil) and all advance, both vacuum and centrifugal advance all in the Dizzy.
see why here,

here is the wiring to it.
if you had spark, you could run the engine on test fuel (spray) no fuel in gas tank even.
http://www.fixkick.com/INJECTORS/89/89-90schem1.jpg


the VR sensor is the instigator of spark , like cam sensor, it creates the first moments of spark this VR sensor is then drives (runs) a tranistor ignitor near it.
This ignitor charges the coil primary then release it and spark happens NOW.
the first test for any car with not running for sure 89s is check the coil for spark. first.
then at the 4 cylinders. next .
watch scotty, pretend it has coil on fire wall and he checks that first. then the 4 spark plugs. (note the rubber meets the road test, with real test spark plug, a win)

the failure. (this test is 120 years old, back to 1900 year.)
https://youtu.be/064Ilsz8Fzg?t=106



then good.
https://youtu.be/064Ilsz8Fzg?t=138

also back firing from the throttle body air horn is a sign of
1: spark wires put on in wrong firing order. (or forgot to change the or plugs 1 by 1 and not all at once? now are scrambled wrong.)
2: someone played the distributor clamp bolt. (it turns and is wrong now , gross timing errors)
3: cam timed wrong.
4: burned valves in head.

but we work the coil first, always, it must have spark at the coil, if ok then check distributor timing from crank to cam to distributor (end to end)

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
02-08-2018, 12:43 PM
Post: #5
RE: 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
Thank you for the help. I found my problem! The dizzy was pointing to #1 on the cap. I moved it 180 to point to #4 on tdc crank and cam and she started right up. Now I just have to fine tune it to get it to idle on its own. Thanks again for the help
Find all posts by this user
Quote this message in a reply
02-08-2018, 10:57 PM (This post was last modified: 02-08-2018 10:57 PM by fixkick.)
Post: #6
RE: 89 sidekick tbi 8v 5spd- Fuel, Spark, comp, no start. HELP!!
sure that happens easy
the cam is timed to #4
the distrib is #1 timed.
(in the manual for suzuki)

ok spark was good at the coil
and spark was bad at the plugs
and timing was waY OFF... OK,, 180 off at distrib and 360degress off a crank, (2:1 ratio cam drive)

GOOD NEWS, HAPPY TRAILS TO YOU!@

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)