Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vitara cant get power above 3000 rpms?
02-12-2018, 10:25 AM
Post: #11
RE: Vitara cant get power above 3000 rpms?
sounds like low fuel pressure to me.
and if true will get worse. all do in that mode.
or the FPR is bad. causing low pressure.

30-37 psi idling (high end is sealevel)
36 to 43 , just key on, not running
and 6 Psi more than idle Pressure seen at WOT. the FPR raise pressure that much near WOT. to about 43psi at sealevel.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
02-14-2018, 06:54 AM (This post was last modified: 02-14-2018 06:57 AM by dell_mare.)
Post: #12
RE: Vitara cant get power above 3000 rpms?
I said before, FPR was changed (spare) recently and after that, engine regain normal rpms (800 hot) and calm sound when idling. Maybe that FPR is bad and causing low pressure and so low performance but I don't have tools to check that pressure. Anyway, after I changed light bulb for CHECK ENGINE and tried trick with paper clip again, nothing happens - I still don't get CHECK ENGINE light when key on.

I can't believe there is someone who care about every Sidekick, Vitara and other Suzis on the world. Many thanks to fixkick for advices and huge data base I found here.
Find all posts by this user
Quote this message in a reply
02-14-2018, 08:17 AM
Post: #13
RE: Vitara cant get power above 3000 rpms?
1.6 16V, 97 ps, 1995, 2doors, 5 manual trans. Vitara. G16B MPI.

for full power, the order below, matters.
good engine, (compression tests pass)
good spark and timed right, base timing good.
then fuel pressure, sure the FPR regulates that but other reasons can cause low fuel pressure, (pump,filter or pinched lines) and the ECU does not know it is low ever, so injects too little fuel if pressure is low.
plenty of air, air cleaner not packed up and choking engines.
next is MAF sensor working right, it reports, air flow, and if under reporting, (even air leaks behind it, called illegal unmetered air , even cracks in the top air pipe, or seals failing there.)
then injectors , under injecting, due to its screens inside clogged (tiny screens 10 micron size) if the car had bad fuel, injectors can packup easy. (try Chevron, Techron injector cleaner in tank)
a melted CAT element inside (honeycomb brick inside it is), if vacuum tests act real oddly or delayed, look here.


The CEL lamp only has 2 wires.
1 is power
the other pin is the ECU, that turns it on with a transistor inside the ECU.
it must glow with keyon, only. or lamp is bad, wires too it or ECU is bad. (some ecu go to backupmode, 10x worse than limphome mode.
backup mode is for dead ECU, and the backup is what I call lawnmower mode, dumb simple, crude injections. and a dead CEL lamp.
you are welcome.


cheers ! to you.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)