Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
89 sidekick electrical problems
02-02-2018, 12:46 AM
Post: #1
89 sidekick electrical problems
The kick runs good, however the dash eng light and fuel gauge goes off, then comes back on on dirt roads. Check eng light always comes on when shifting gears and I let off the gas. This is how I know the gauges arn't working when check eng light doesn't come on. Gauges effected are temperure, gas and check eng light. Some times they work sometimes they don't.
Find all posts by this user
Quote this message in a reply
02-02-2018, 02:29 AM
Post: #2
RE: 89 sidekick electrical problems
89, the ECU that makes no spark.
very unique in the EFI world. until 1991.
1.3L is carb
1.6L is EFI,\

seems EFI
seems loose connectors or rusty for sure.
so the cluster is losing power. simple on this car, cave man, compared to my new jeeps.
the tachometer goes dead to or is it mssing that, is car 2wd or 4wd.???? 5speed?
pin 5 in the cluster is power 12vdc.
black white wire to fuse #8
fuse 8 = IG COIL. if that is failing engine dies. (no spark)

so the that wire (color above) goes to cluster and is cut.
or the cluster connector on the rear is dirty. or got water damage or both.
hit the top of the dash above cluster does the gauges and lamps work now? or blinks, bingo if yes.
see the 4 links here 89, full schematics there.
http://www.fixkick.com/schematics-run.html

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
02-02-2018, 08:02 AM (This post was last modified: 02-02-2018 09:50 AM by bruski.)
Post: #3
RE: 89 sidekick electrical problems
(02-02-2018 02:29 AM)fixkick Wrote:  89, the ECU that makes no spark.
very unique in the EFI world. until 1991.
1.3L is carb
1.6L is EFI,\

seems EFI
seems loose connectors or rusty for sure.
so the cluster is losing power. simple on this car, cave man, compared to my new jeeps.
the tachometer goes dead to or is it mssing that, is car 2wd or 4wd.???? 5speed?
pin 5 in the cluster is power 12vdc.
black white wire to fuse #8
fuse 8 = IG COIL. if that is failing engine dies. (no spark)

so the that wire (color above) goes to cluster and is cut.
or the cluster connector on the rear is dirty. or got water damage or both.
hit the top of the dash above cluster does the gauges and lamps work now? or blinks, bingo if yes.
see the 4 links here 89, full schematics there.
http://www.fixkick.com/schematics-run.html

It's 5 speed manuel--4X4 Thanks for quick answer. Going out to check. No tach. Beat the dash=did nothing. Where is this cluster located? High in dash?
Find all posts by this user
Quote this message in a reply
02-02-2018, 10:48 AM
Post: #4
RE: 89 sidekick electrical problems
the speedometer instrument cluster.
is one thing, unless removed and dismantled.
it has harness there
and a connector set.
that plugs in to the rear of the cluster
here is most ive seen.

http://www.fixkick.com/sensors/speedo/sl...index.html

possible causes,
photo 1 in above slide show, reseat those 2 connectors
or someone got cute and hacked the wire up to that connector group to put in some (endless) aftermarket toy, and needed power and attacked this wire, black white wire. look for damage.
the fuse end is not failing or the car stalls.
its form the fuse to the dash harness then to the cluster. that is failing,. reseating connectors tops the list of easy.

http://www.fixkick.com
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)