Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
engine rpm surge. help needed.
12-07-2017, 02:02 AM
Post: #11
RE: engine rpm surge. help needed.
btw the suz spec on cable slack not 3sp
is 10mm, almost 1/2 an inch, you do know that right?

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2017, 02:48 AM
Post: #12
RE: engine rpm surge. help needed.
no i do this post. response in line., IN CAPS.


so i drove it about 10 miles. cel flashes 12 the entire drive. get home. GOOD ! super. shows no intermittent , a good job. known that.


IR pointed on top of thermostat housing reads 182F.. GREAT:

i attempted the check the TPS.
oh boy.. first off... used a .025feeler.. could not find a 26... hope the .001 doesnt matter much. (THAT IS AOK)

TIP remove feeler BEFORE opening throttle.? WHAT DOES THIS MEAN>??? TIP?

took me 30 mins to find it! (THE STOP SCREW????)
lol (it fell)WHAT FELL, THE FEELER FELL? (I LIKE THAT PHRASE, FUNNY TO ME) YES SICK.
ok readings with feeler inserted at idle (and yes i have 7-8mm of cable play) 10MM IS FACTORY SPEC. BUT 8MM IS OK.
THE STOP SCREW MOST BE HITTING THE BELL CRANK THAT TV THING WITH A CABLE IS BELL CRANK (AIRCRAFT TERM USED WITH CABLE DRIVE EVERYTHING ON OLD AIR CRAFT)
THE STOP SCREW STOPS THE BELL CRANK FROM LETTING TV CLOSE, AND SPOTS IT AT NEAR .0005 TB BORE WALL TO TV PLATE END. THAT IS ITS ONLY JOB, JUST THAT.
AND MOST BE RIGHT TO BEGINWITH OR ALL STEPS MANY WILL BE WRONG, NOT JUST IDLE BUT SETTING SPARK TIMING, THIS MUST WORK.


i got a .051.. with feeler removed. (ARE YOU SAYING HERE .051 AT STOP SCREW TIP HAS HUGE GIANT GAP THERE TO START? BEGIN?
YES: THEN HALT HERE AND FIX THAT NOW. A MUST.
OK I FORGOT TO SAY, BADGUY (P0, PREV. OWNERS) LOVE TO DO ANYTHING, SO IF THERE IS GAP THERE THAT MEANS THE GOFFY GUY UNSCREWED THE DONT TOUCH SCREW LIKE 20 TURNS, WOW, NEVER UNDERESTIMATE BAD GUYS. DID HE????????????
SORRY NOW YOU GET TO DO MY NINCOMPOOP PAGE, SORRY IF YOU HAD THIS HAPPEN TO YOU !!!! HOPE YOU CAN STAND CAPS, BUT IT MAKES INLINE ANSWER EASIER.
LETS START AT GROUND ZERO, THE CABLES ALL SLACK, AND TV IS 99.9999% CLOSED (.0005 BORE GAP YOU CANT SEE) 3 ZEROS THERE SEE? NOT 2,

THEN LOOK AT MR, STOP SCREW IT MUST BE TOUCHING THE THROTTLE BELL CRANK LANDING ZONE,(JUST LIKE WHEN CAR WAS NEW), SET TO .0005" tv BRASS PLATE TO WALL BORE.
THE STOP SCREW AT THE OUTSIDE BELL CRANK, HAS NO GAP EVER ON ANY 16V MPI TB. NOT ONE. IF YES THIS CAR IS HACKED !@ PLEASE THIS AND WE CAN FIX IT EASY.
THE OFFICAL FIX FOR ABOUT AT SUZ, IS NEW TB FOR $1200, SAME WITH HONDA. AND TOYOTA.

it was a .042 or 62 dont remember.. (WHAT IS THIS?)
doesnt matter because moving the throttle off idle (and plying jinga with my feeler gauge) the DMM goes to OL.
THIS IS A CALIBRATION, STEP,
1: STOP SCREW IS LANDED ON BELL CRANK SPOT.
CLEAR AS DAY HERE. OFF CAR, IS CLEAR AS DAY, ZERO GAP THERE. AND .0005' TV BLADE (BUTTERFLY ) TO WALL GAP IS SUPER SMALL SO SMALL HUMANS CANT SEE IT.
eems i will have to fire up my desktop pc for images. ive been posting from my cell phone. (site not cell friendly) so i drove it about 10 miles. cel flashes 12 the entire drive. get home. IR pointed on top of thermostat housing reads 182F.. i atempted the check the TPS. oh boy.. first off... used a .025feeler.. could not find a 26... hope the .001 doesnt matter much. TIP remove feeler BEFORE opening throttle. took me 30 mins to find it! lol (it fell) ok readings with feeler inserted at idle (and yes i have 7-8mm of cable play) i got a .051.. with feeler removed. it was a .042 or 62 dont remember.. doesnt matter because moving the throttle off idle (and plying jinga with my feeler gauge) the DMM goes to OL. it only reads with throttle closed. anything but closed... even full open is OL. ????? i think i did it correctly? bottom 2 pins. this is telling me the tps is fubar? if so... i have no codes and it seems to run fine besides the 1500-1900 surge. i would think it would not run at all? also to add..when i cold started it before my drive.. idle was at 1500...when i returned. it was at 800... thats odd. also have a bad trans leak at back of pan.. replaced gasket 2 times.. tq'd properly. pan not bent. still leaking. this is another day. what a messy pain. 2x still leaking. convinced it may not be pan... as this second time i coated both sides of the rubber gasket in japanese Rtv. yes i did... this is my one and only "nincompoop" move so far. still leaking... arrrgghhhh... oh forgot to add... its a federal vehicle. has a brand new 4 wire Denso 02 sensor. new exhaust. long tube


it only reads with throttle closed. (YES THE SWITCH IS CLOSED NOW)
anything but closed... even full open is OL. ????? THE SWITCH OPENS AT 0.026 INCHES OF BELL CRANK ROTATION, AND STAYS OPEN FROM THERE TO WOT, ON ALL g16A/B ENGINES.

i think i did it correctly? bottom 2 pins.
this is telling me the tps is fubar? NO IT DOES NOT, ITS ONLY A SWITCH ON PIN 2 , IT IS NOT A POT OR A RESISTOR THERE, IT IS JUST SWITCH BUT IS CARBON NOT GOLD.
THE POINT OF CARBON IS, GOLD IS PERFECT CONDUCTOR AND CARBON IS NOT, EVER. (A DIAMOND IS CARBON TOO) THE SWITCH IS GOOD LEVER STROKING CARBON.
THE CARBON IS ABOUT (A PAD) ABOUT 1000 ohms end to end.
the ECU knows this, a fact, the ECU know this, (about) 300 to 500 ohms or less good closure status (idle reg = true) the switch over 500 ohms is open
in fact it goes from 500 to 1000 then the contacts go to pure ceramic insulation and infinity in .026 inches. travel
0 to 500 short
1000 to infinity open, the ecu actually uses volts only.
0v or newer is closed
5v open or may be over 2.5vdc, (IDK) only suzuki knows the exact threshold and and does not say , but does say the magic 500 ohms thing, or 300 in GM books.
THE CALIBRATION IS SETTING THE TRIP POINT, 0V TO 5V OR FROM 500 OHMS TO INFINITY AT 0.026 (25) INCHES OF TRAVEL THIS IS A CALIBRATED STEP, WOT HAS NOTHING TO DO WITH THIS.


if so... i have no codes and it seems to run fine besides the 1500-1900 surge. (IT STILL SURGES WITH IDLE SWITCH AT 0VDC ? RUNNING)?????
i would think it would not run at all? WHY THINK THAT? THE ENGINE HAS FUEL, AIR AND SPARK WHY THING IDLE CONTROLS CAN STALL AND ENGINE,OR OUT OF CONTROL IDLE WILL
IN FACT 1500 RPM MAKES HUGE HP. BIG POWER.
WHAT I THINK IS YOUR PO TRIED TO HIDE THE REAL TRUTH., THAT IS WHAT i THINK... SEEN THIS VAST TIMES, THE EVIL ONES DO THAT. HIDING BAD IS THAT.
IT'S LIKE PUTTING DIRT UNDER THE RUG.



also to add..
when i cold started it before my drive.. idle was at 1500.. THAT IS IAC VALVE NORMAL FAST IDLE good. , AND CLOSES NEAR 150F ALL DO , GOOD.
.when i returned.
it was at 800...THAT IS NORMAL, BUT WHAT ABOUT REGULATION TESTS NOW????????
thats odd. WHY IS 800 RPM ODD?
lso have a bad trans leak at back of pan.. replaced gasket 2 times.. (THE KICK DOWN SEAL FAILED AS CAN THE SHIFTER ROD SEAL AS CAN TAIL SEAL)
tq'd properly
pan not bent. still leaking (TAKES CAREFUL CHECKING TO SEE EXACT STOP ,USE DYE AND UV LIGHT?
. this is another day. what a messy pain. 2x still leaking.
convinced it may not be pan... as this second time i coated both sides of the rubber gasket in japanese Rtv.
yes i did... this is my one and only "nincompoop" move so far. still leaking... YES I HATE LEAKS TOO, AND ALL ARE A PAIN...
arrrgghhhh... oh forgot to add...
its a federal vehicle. has a brand new 4 wire Denso 02 sensor. new exhaust. long tube


THE CAR STARTS AND RUNS 1500 OR MORE RPM COLD ALL DO , AND FASTER OF COLDER, BY ACTIONS OF THE IAC ALONE, IT IS OPEN PARTWAY OR FULLY AT THE NORTH POLE ARCTIC .
THE THE WATER HEATS.
AND AT 150F THE IAC CLOSES 100% FULLY., ANDING THE COLD START FAST IDLE
AT THIS TIME THE ISC GOES ONLINE (NOT OF THE IDLE SWITCH IS BAD OR SET WRONG)
THE ISC IS 2 THINGS, NOT ONE, IT IS A isc solenoid valve (PWM ) modulated just like hondas (some) and the ECu does all modulations.
the ECU holds idle at 800 hot(ac off)
it is just like cruise controls no differences at all except this is RPM regulation and cruise is MPG regulation but works exactly in the same way.
its called a computer servo loop.
the software is simple really, too simple in fact,
if rpm rises it lower air
if rpm below 800 it cuts air (ISC does the cut) by commands.
if you car still surges (a vary bad thing and needs to be fixed before young teens drive car) say so, say when .... surely not hot at idle ever, if yes tell when exactly.

this is called a servo control in engineering terms. or tech, no matter what.

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2017, 03:06 AM (This post was last modified: 12-07-2017 03:19 AM by fixkick.)
Post: #13
RE: engine rpm surge. help needed.
try to know i cant see car or you,
if the PO turned every screw on car wrong , i cant see that, and is common
they see it mess up and Amateur fiddles (not you , them) every screw on car,
TPS wrong
stop screw wrong
slack wrong (1 to 3 cables)
bleed set wrong
and more.
that is why new cars all this was removed. all of it.
TBW and fixed spark hard landed crank sensors, with no adjustment allowed !all things are 100% under computer controls , not even lash can be set.
or they (PO) do that to hide a REAL problem. PO previous owner, or the Devil him self?

all gone. and much better i guess.

OBD1, oops vast things to mess up , plus all the normal stuff.

tell me there are no leaks behind the MAF.>? ok>
a leak there, too big and the engine injections go lean, beyond 02 (command authority) and surges.
lean = surge. ( comments are HOT engine, yours is perfect !)
but only if the bad is so bad the ISC cant keep up. see? (we call that outside its command authority)

the ISC (servo) can NOT correct the following RPMs. (by any cause or fault causing this.)
about, there is no spec. on this, varies by out door temp and engine wear
1: below 400 rpm the isc goes dead or hunts. (EGR stuck open is classic here)
2: above 1200 rpm the is goes dead(off line) or goes nuts or hunts. ( iac stuck open or bleed turn out 100% ) most true vacuum leaks with maf engine drop idle speeds but not if fault# 2 is engine stuck rich now) sadly no scan tool so see fuel trim,.. so , hard to diagnose.

if the ISC does the hunt that is illegal now in the usa. (wiki toyota 1billion dollar law suit on that , and not there fault either) oddly toyota is clean suzuki is(was) dirty. the IRONY ! of that SHOCKS me,
if the lean-ness only causes the hunt alone, that is just bad luck. (hunt = surge ,ok?) stuck lean or stuck rich is a first order failure not idle controls.
idle is the last thing , to work after all else is ok, see?
IN modern car we go, gee the fuel trim goes nuts (lean) as then engine surges slower, oops that is fix first thing, on OBD2 cars, not surge.


if you worked on carb cars it did this all the time , no idle controls then. zero. no puters, nada. just pure mechanics then.
so if carb fuel mixtures are wrong so will be idle speeds. RPM.
if AFR is normal, air leaks now , cause lower rpm (normal = lean = less power and lower rpm) and surges. lean burn = surge.
if AFR is rich (choke on?) and air leaks now, the engine screams, and no surge. and a danger to drive (teens? driving? )
the same rules apply here.
the AFR if wrong , can cause surge. or gross rich misfire, that is not really a surge, its just misfiring, heard and felt. and even seen.


now demo of bad
all 8v TBI cars 89-95
defeat the dash pot by pulling its vacuum hose, (even plug the end with golf tee (no can suck air)
NOW see the silly suzuki ECU surge the hell out of the isc, (illegal that is now)
and is a danger. to many, not me grand-dad say , "son you can turn the key off or go to neutral in 1 second flat, learn that son"
or any large vacuum lean, and omg, it surges like a PIG with 100% power on tap . shift to drive and it burns rubber.. on ice, oops worse.

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2017, 04:41 AM
Post: #14
RE: engine rpm surge. help needed.
forgive me. at work. will read all of this tonight. lots of info!
Find all posts by this user
Quote this message in a reply
12-07-2017, 02:05 PM (This post was last modified: 12-07-2017 02:08 PM by Rapom.)
Post: #15
RE: engine rpm surge. help needed.
ok ok where to start.. im just going to list things i know to clear some stuff up before we get too deep..

1. .042 or .062 was referring to a reading of ohms with feeler gauge installed vs not installed.

2. so the tps may actually be ok?

3. idle switch is what? at 0vdc? i never tested voltage just ohms so far

4. 1500 cold idle is intermittent. for example today, both cold starts (and i mean cold) were at 800 rpm.

5. does not surge (hunt) at idle at all. only way to produce this is to slowly throttle it up to 1900 rpm in park or neutral hot or cold. when 1900 is reached it will drop to 1500 on its own then raise back to 1900, then 1500..then 1900 over and over never ending as long as i hold my foot very steady on the throttle (very very light throttle input) if i apply more throttle, rpm raise and smooth out, no more surge, if i let off of throttle, or let it idle, surge stops.

6. i dont have cruise cont. (forgot to mention eons ago)

7. i have zero before maf leaks (im a stickler about this)

8. i had a feeler gauge between the stop and ball crank and accidentally opened the throttle causing my feeling to fall down (lol)

9. maf screen is intact. slightly dirty. not like mud or debris.. just light normal dust. i will clean with approved cleaner asap.

10. the header is stainless steel. nice but expensive. $280? BUT it DOES have a provision (special cut out) for the egr to flow and function properly., cat is directly behind header.

11. 10mm is 1/2inch yes. (close enough)

12. .51 was an ohm reading, not a gap measurement, and i left out a zero .051 is correct

13. the ball crank is resting on the stop screw. there is a shiny worn spot where its been resting for 23 years Smile i dont think this was ever tampered with

14. the cone filter i was talking about was the size of a D battery and stuffed into the intake hose where i believe factory would be a baffle? see pic. what kind of idiot puts a filter in line before the maf!?!!?!?! who does this!? nincompoops! lol i have the hole temporally taped tightly and clamped until i can find a baffle

70yrs young huh? you are a smart mother. got my head spinning

   
Find all posts by this user
Quote this message in a reply
12-07-2017, 10:34 PM (This post was last modified: 12-07-2017 10:43 PM by fixkick.)
Post: #16
RE: engine rpm surge. help needed.
.042 is not correct, sorry you have auto-ranging meter and actually shows, .042k (k =1000) so really is 420 ohms Ω, with out the words, ohms or inches, i got "Corn_Fuzed"(sic)
yes 420 is ok! 400 to 500 Ω are all ok.

yes, one can set the THE calibration using volts too, Suzuki never tells that but you can, at the 0 to 5vdc transition point, it is a switch but it's only a comment.
I bet 800 holds now from N to Drive. right:?

cold 800, is wrong for sure, overnight parked cold, other wise its a hot soak not so cold start, coolant temps actually matter here, the IAC is same as the thermostat a wax pellet driven device.
the IAC is open very wide, cold , lets in lots of air, the 8v version opens to .040" gap at 40F (in the refrigerator) temp. -10f opens to 0.060" , your IAC can not be see like the 8v can .
The water temps dictate cold idle RPM , totally. via the actions of IAC (thermal cold idle valve)

0.051 ohms is is 0.051k or 510 ohms autoranged, sorry, your ISC is ok,, most are 500 ohms closed, (carbon landing zone iinside the TPS does that)

a filter FOUND from the maf side to the intake wow, that is an all time first. and crazy... lowers power for he joy of only that, wow.
look ,lets work line 5
line 4, i can't comment on until, water temp is know. my guess water is 30F. and IAC is messed up. but ,we can test it later.
5Smile
" does not surge (hunt) at idle at all.
only way to produce this is to slowly throttle it up to 1900 rpm in park or neutral hot or cold. (great, it does it parked, super more easy to fix.) but forget code as #4 effect above, is messing up cold. )
when 1900 is reached it will drop to 1500 on its own then raise back to 1900, then 1500..

then 1900 over and over never ending as long as i hold my foot very steady on the throttle (very very light throttle input) if i apply more throttle,
rpm raise and smooth out, no more surge, if i let off of throttle, or let it idle, surge stops.
on a hot engine,
that is only caused by a few things,
TPS set wrong and the switch idle pin 2, is not at 5vdc (but is 0v) at 1900 rpm. held by hand or foot. can cause a war of the foot to ISC, (logger heads fight) and surge.
or the MAF is doing that.
the maf does it pass the rap test,, idling hot gently rap or knock it with back side of screwdriver handle? and not change RPM hot idle? or at 1900 rpm? held by hand. rap rap rap. test.?
bad FPR?? fuel pressure is not holding steady at 1900, (the FPR loves to fail now, its really too old, to work very well. does the FPR at vacuum hose leak fuel when the hose removed from FPR)?
yes then it's bad, straight away.

the surges is for sure caused by. (physics)
1: fuel pressures surging at fixed 1900. rpm held by you. (FPR)
2: TPS idle,switch not at 5v (5v means logical 1, and means idle controls are disabled) to the ECU.
3: MAF surges (it can be bad or just dirty) and cause it output to rise and the ecu adds fuel and it surges. (no scan tool to see if closed loop mode fails at 1900 rpm like on 1996 we can..)
5: vacuum leaks (lots possible). and could be a bad iAC, the wax pellet inside bad and it sticks closed or sticks open or goes mad(RANDOM). (see my test below)
6: injector leaks. or partial clogs or sticking.
7: 02 readings not right. (exhaust leaks near by , top list) wow SST headers, sure and very nice. since the factory headers love to crack...


now to prove the IAC failure.
see this photos and pack this port in clay. on hot engine, 150f and up.
the iAC input port in red here, is plugged up some how by you,
if surge is gone, IAC is bad, if not gone other problems as you know !


http://www.fixkick.com/IDLE-AIR/Slide_Sh...ge_24.html

topic
vacuum leaks, in most cases normally there are 2 kinds of leaks,
metered and un-metered air, leaks (vacuum) the latter is MAF seen leaks
if engine ECU is running at STOICH, and un-metered leaks happen rpm drops
if metered leaks happen (like Mr. IAC) then RPM rises.
polar opposite effect (only on hot engine,) cold , all leaks are faster RPM due to engine is in fuel enrich mode cold.


refr, photos of IAC . not easy to test, and removing it the bolts snap (6mm) best test are with TB remove, but we can do it on car.

http://www.fixkick.com/IDLE-AIR/Slide_Sh...IAC_w1.JPG

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-07-2017, 10:36 PM
Post: #17
RE: engine rpm surge. help needed.
you are getting close ! cheers!

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-08-2017, 12:21 PM
Post: #18
RE: engine rpm surge. help needed.
ok. long work week. i should be able to do some tests sunday for sure.
i plan to check FPR vac hose for fuel..clean the MAF. and do your tap tap tap test on the maf. im going to putty up the port inside the throttle body (for testing)... a few things ive been thinkin about..

fuel filter is old and rusty. it needs replaced no doubt. but the rust on the line makes me a bit... you know...

another thought. so we know both throttle cables (thrttle and kick) were adjusted WAY of of whack. and that also the TPS sensor is turned/maxed out one direction.... did they fubar the cables and then adjust the tps to match the cables??? if yes... who knows why. but i know 2 things..

1. this surge was not there untill i corrected both cable adjustments (took my time and dialed them in perfectly)

2. i never adjusted the tps... (nor do i know how)

ehhhh???
Find all posts by this user
Quote this message in a reply
12-08-2017, 11:26 PM
Post: #19
RE: engine rpm surge. help needed.
(12-08-2017 12:21 PM)Rapom Wrote:  ok. long work week. i should be able to do some tests sunday for sure.
i plan to check FPR vac hose for fuel..clean the MAF. and do your tap tap tap test on the maf. im going to putty up the port inside the throttle body (for testing)... a few things ive been thinkin about..

fuel filter is old and rusty. it needs replaced no doubt. but the rust on the line makes me a bit... you know... Rust has no friends,

another thought. so we know both throttle cables (thrttle and kick) were adjusted WAY of of whack.

and that also the TPS sensor is turned/maxed out one direction.... (was)?
did they fubar the cables and then adjust the tps to match the cables??? (my guess not that smart, they just jam it in wild attempt to lower idle speeds)
if yes... who knows why. but i know 2 things..

1. this surge was not there until i corrected both cable adjustments (took my time and dialed them in perfectly)
you do know all cables must be slack and why, its dangerous, and doing this wrong is why TBW came in to effect (no more cables to mess up and kill drivers)
if they are tight, there is no way in the world to set any TPS, its impossible...
not only that there is a way on some TB to mount the TPS wrong, (off and put on wrong not indexed) and does the same thing as tight cables. engine RACES
as the backside of the TPS jams the throttle open. again, TBW wins. throttle by wire,,, its hard to get inside the head of Mr. Badguy or nincompoop.
starting up and A/T car with idle at 2500 and shifting in to Drive, causes, some folks to panic, one old lady ran over her kids... many times.

we dont know the surge cause. (is it sensors, or actuators yet) for sure it's one, or just leak (vac) if we had a scan tool it be bingo day.
working EFI blind is hard nor was fun. no tools.blind. a challenge sure.


2. i never adjusted the tps... (nor do i know how) (past tense?) (did)?

ehhhh???

the TPS cal is only because this ECU is old and slow,(over taxed)
autocal was not possible then, just like on a new car, open the FSM search the word auto or learn modes, vast things do that. now. but in the dark ages
of 1987 (when it was designed. 30 long years ago, remember computers thin.(slow and dumb) bingo.


The TPS calibration really is 3 feeler gages, GO, NOGO, CAL. 3 steps, in the manual. the pages are there my page, fsm links.
http://www.fixkick.com/sensors/tests/TPS...tml#matrix
The TPS must be closed at idle no matter what (switch) or its can be a danger to any new driver, (read bad driving lessons)
The TPS is set with .026" preload, that means that it is closed that far in the rotation from THRESHOLD.
THE TPS is not to be closed after .026" (.037) there is .010" uncertainty zone there and must go open at the NOGO point, or the Idle servo will fight the drivers right foot. (note the GM uses there own numbers , and is odd that)

the book pages real are here. page 1:
http://www.fixkick.com/sensors/TPS/TPS96-98a.jpg
see figure C1-11 see those index pins,see how easy it is to land these (installed) this sensor wrong? and even cause it to jam the TV?
it can be installed wrong, and the TV can not close, or installed wrong #2 and the TPS is lagged.

and
page 2 next from the 96 manual and is the same exact proceedures on all 16v 92 to 98'
http://www.fixkick.com/sensors/TPS/TPS96-98b.jpg
step 4 here is the nogo step, using GM sized (odd) feeler.
Step 5 is The GO step, feeler #3 in the set, .020" this assures that idle switch never is open at .020" there are in fact 3 steps and 3 feelers used.

if you read a Toyota manual 92 era, its much the same thing. legacy OBD1 is not unique to suzuki at all.
figure C1-14 shows the magic, 500 ohm rule of carbon there.

here is a tps guts off a damaged engine, from wrecking yard damage.. was hit on engine pulls.
it cracked the ceramic TPS base.
the throttle angle is 5000 ohm POT. (variable resistor seen here) seeing helps no? seeing the real world really does for most.

see the tps idle side there? this is all passive electronics, not transistors here, zero. it's just CARBON.
the TPS wiper pins device is not seen here, its gold wiper.

90degrees is WOT full throttle. the idle switch cliff ( i call it or infinity thereshold) is seen I think at the shinny spot see and 3O-clock there)

http://www.fixkick.com/TPS/TPS-v8a.jpg

how is that.?

surge does have many causes.
What is done is assume all else is bad, prove otherwise then the MAF is bad.
the maf is the most hard thing to test and prove bad (not dead)
after all when and engine surges it sucks more air and the MAF output rises.
but (chicken and egg rules) what if only the MAF output messed up(all by its loansome) the engine AFR would then go rich fast. causing faster RPM.
that is because STOICH is on the lean side or power. see?
on the contrary side, if the maf lied and shows lower output (ecu knows this is less air) the engine would go leaner and slower from STOICH.
one way to prove that is with a real scan too.
you see surge, (goes higher RPM that right foot asks for!)
does closed loop end there,? did the TPS throttle angle change (must not)
does LTFT go wrong? (long term fuel trim(short is to fast for humans , ignore it)
did the rpm rise and MAF did not (oops it is fibbing if yes)
did injection rates change.
all this is OBD2 stuff but is also in the OBD1 too, if you look, see that here.

this raw data was (captured (with communications tool I have) note that OBD1 , we must convert binary to analog values, unlike OBD2.(its free ride that)

http://www.fixkick.com/ECU/Tech1/full_scan2.html

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
12-08-2017, 11:35 PM
Post: #20
RE: engine rpm surge. help needed.
ever seen old Honda, Crome?
honda hackers are the best in the world, did all this long ago,, no parallel exists in the suzuki world. 1992. to 1998.

http://www.hondash.net/2017/02/modified-...d-ecu.html

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)