Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6 Swap Injecton problem
03-02-2017, 03:15 AM (This post was last modified: 03-05-2017 03:43 AM by fixkick.)
Post: #11
RE: 1.6 Swap Injecton problem
Exploring the car i found these tags (images attached)

And i found a 1.6 distributor too, could this be useful? (image attached too)


I tried to swap the the tps sensor between 1.6 tbi and 1.3 tbi (i am sure about this but correct me if is not, the tps sensor are all equal), i tried to regulate a lot of times, but using another suzuki manual that i found online, in these days i'll try again.
In your website this regulation is explained better and with different values of the feeler gage from what i used.

I'll try

Goodbye


Attached File(s) Thumbnail(s)
               
Find all posts by this user
Quote this message in a reply
03-02-2017, 05:21 AM (This post was last modified: 03-05-2017 04:26 AM by fixkick.)
Post: #12
RE: 1.6 Swap Injecton problem
UPDATE

I tried to connect the tester and verifying the OHMS (2K) with the different feeler Gage inserted, with the 0.012 (0,30 mm For me) it's stay at about .300 and if i wait for it drops to about .270, with the 0.16 (0.4 mm) is about .400, with the 0.20 is 1.

Quote:(edit by me) .300 is 300 ohms and "1 ." is infinity. note the spaces
the idles switch is odd thing,,
many vary from this range,
50 ohms, and rises to 500ohm then very abruptly goes to infinity (open circuit) its really just a very crude carbon switch, your's is set correct i think, the 1.0 reading on meters, means infinity, other meters show, OR OL, for over range, or
my fluke meter shows, .1 to .3 ohms for shorted leads together, (lead resistance ) then with open circuit it shows "1 ." shows 1 and space and dot far away (8022b fluke)
what happens on the car as you move throttle off stops, is at .020"(,5mm) voltage changes from 0volts to 5vdc, this 5v tells ECU you are cancelling idle mode. (begin acceleration)
if set wrong 2 things happen,
1: idle mode never happens
2: or fights the drivers right foot. actions. (cause gross hesitations, at first, then you win 1 second later.,)


Just tried the car, it works the same and it's hard and too variable this problem to describe it correctly , with the ECT sensor connected when i touch the pedal the car bogs and is not only on 1000 RMP even higher but it's likely to shut off the engine is not a simple hesitation.

Goodbye
Find all posts by this user
Quote this message in a reply
03-02-2017, 06:18 AM (This post was last modified: 03-02-2017 06:21 AM by fixkick.)
Post: #13
RE: 1.6 Swap Injecton problem
full power loss is NOT The TPS SENSOR. THE TPS DOES NOT LIMIT WHAT THE MAP DEMANDS, THE MAP MUST WIN? SEE?
it's map (MY GUESS)
the map must read correctly or there will be no power on any G engine TBI
shortest list: Possible your case.

1engine good, CAT gone. so engine will breath 100% and pump air 100%, cylinder compression at 150+psi min, that's 10bar.!
2: good spark, and must advance past 30 degrees, at high RPM or power will be lost , huge loss of power,
2a; all 4 cylinders good spark. (when power loss happens is there felt/heard misfiring?)
3: map most function correctly or the ECU can not match fuel to air, and goes lean and bogs,
4: fuel pressure is ok,sure, but injector must not be clogged, or its Screens.

there are simple test for each
using simple tools gauges, and a DMM meter.
the above is the correct order,
good luck
and cheers.

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
03-03-2017, 10:18 AM
Post: #14
RE: 1.6 Swap Injecton problem
(03-02-2017 06:18 AM)fixkick Wrote:  full power loss is NOT The TPS SENSOR. THE TPS DOES NOT LIMIT WHAT THE MAP DEMANDS, THE MAP MUST WIN? SEE?
it's map (MY GUESS)
the map must read correctly or there will be no power on any G engine TBI
shortest list: Possible your case.

1engine good, CAT gone. so engine will breath 100% and pump air 100%, cylinder compression at 150+psi min, that's 10bar.!
2: good spark, and must advance past 30 degrees, at high RPM or power will be lost , huge loss of power,
2a; all 4 cylinders good spark. (when power loss happens is there felt/heard misfiring?)
3: map most function correctly or the ECU can not match fuel to air, and goes lean and bogs,
4: fuel pressure is ok,sure, but injector must not be clogged, or its Screens.

there are simple test for each
using simple tools gauges, and a DMM meter.
the above is the correct order,
good luck
and cheers.

I Decided to put on the car the 1.3 fuel injector, and the old 1.3 Ecu and see what's is going on.






I'M SERIOUS

Thank you seriously for the time that you gave to me, i appreciate all you're devotion giving to me a lot of advices and techincal informations.

This is a kriptonite Car And i am Superman

I'm Sure that one way or another i'll make this car works fine Removing ALL THE PROBLEM THAT I HAVE CREATED BY MYSELF.

You're a Patient and Good MAN

Best Regards




P.S. Just to know, HOW BAD IS MY ENGLISH?
Find all posts by this user
Quote this message in a reply
03-05-2017, 04:09 AM
Post: #15
RE: 1.6 Swap Injecton problem
what makes you think THE G16a ENGINE is good? (just because it idles proves little) I've seen them do that, , with near flat cam lobes. (cam a train wreck)(but is undriveable)
Ever check compression, over 150PSI(10bar), wide open throttle)?
Flash codes 12. (means only wires not broken to sensors or shorted)
spark advance work correctly?. (using any automotive timing light ever made even my 1970 light works perfect still, I have 2, old and very modern) it will advance 30degrees or more (left of scale , huge)
you can NOT mix distributors. (ecu must match Distributors)
The ECU must have a MATCHING MAP and ECT. sensors, you can NOT mix them, and 10x that in EU... they have up to 7 TYPE engine classes there for G16 vitara. (unlike here we have 2)

you can not mix, most those parts presented!!! (that 56b70 only works with 1 distributor, and will NOT like SAMMI sensors,)
stick to the Samurai EFI , end to end, get that working, then play swap parts , 1 by 1 and learn that most won't work or many in your box are just bad or wrong parts.

all we really know here: (IIRC)
is what?, engine idles ok.
fuel pressure great. (tested)
and some kind of power loss, not CLEARLY stated.
we know it likes the ECT unplugged, but that trips limp-home , HIDING TRUE CAUSE of failure!!!
do you know what limphome does, well for one thing IT SIMULATES THE PART removed, and does so with CRUDE METHODS, horrid rich, and retard timing.. and no idle controls.

power loss is complex so needs clear statements .
I can't drive it ,
nor hear if misfire?
or smell the unburned fuel or its black smoke,during that event.
or see the spark tips turn black. or drip raw fuel. or other gross contamination to same.
I can not hear or feel the engine shake from misfire.
i can not feel the bog
I can not feel power, during wide open throttle , (normal or dead weak,)

but we do have lots of Franken-Sammi's here, lots.

The old sammi system may run the G16a , up to 80% power is my guess, or who knows? but will have good engine power. 300cc more flows. (I think the SAMMI map sensor can handle it, but that is theory (a 1 bar sensor)

when the SAMMI sees 0 bar vacuum (near ) at WOT, it uses fuel flows for 1300 cc not 1600 !, so will be lean, wide open throttle.! count on it!
This is why most the guys here, swap engine , harness and 100% of all G16a EFI parts and sensors, The whole package, saving most or all the grief you have now.
that is my best guess so far, not driving it.(or seeing it)

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
03-05-2017, 04:10 AM
Post: #16
RE: 1.6 Swap Injecton problem
thanks for sharing body tags photos. great examples.!!!

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
03-08-2017, 05:00 AM
Post: #17
RE: 1.6 Swap Injecton problem
(03-05-2017 04:10 AM)fixkick Wrote:  thanks for sharing body tags photos. great examples.!!!

IT'S ME AGAIN Smile

I Called the guy who sold me the ECU, I can buy from him the right dizzy for 40 bucks, 33100-56B11, it has 4 pins.

Is there a way to connect this on the original samurai harness, just to try if it can works (the original samy distributor has 3 wires)?

I'll anyway buy a 1.6 vitara harness (even if the hunting will take a long time for sure), the guy will me send the VIN code of his car, and i will be able to find the right harness to put on my car.
Find all posts by this user
Quote this message in a reply
03-08-2017, 05:32 AM (This post was last modified: 03-08-2017 05:36 AM by fixkick.)
Post: #18
RE: 1.6 Swap Injecton problem
(03-08-2017 05:00 AM)loe92 Wrote:  
(03-05-2017 04:10 AM)fixkick Wrote:  thanks for sharing body tags photos. great examples.!!!

IT'S ME AGAIN Smile

I Called the guy who sold me the ECU, I can buy from him the right dizzy for 40 bucks, 33100-56B11, it has 4 pins.

Is there a way to connect this on the original samurai harness, just to try if it can works (the original samy distributor has 3 wires)?

I'll anyway buy a 1.6 vitara harness (even if the hunting will take a long time for sure), the guy will me send the VIN code of his car, and i will be able to find the right harness to put on my car.

sorry i have no USA sammi books for 94 only the one EFI drawing
and for sure no, EU books, for Sammi, harnesses... (only parts lists)

so you are attempting to cross wire 56b ecu to a 81C70 harness, hooo hooo,, "trumpets blaring"

wow, that is a hard row to hoe?

id have both books on both cars side by side. both full service manuals .
really hard and now you get to make the 56b ECU happy with all matching sensors, and actuators.

ouch. (way out of my pay-grade and books)

sorry

we move engines and all parts, and harnessed to the new car, not doing this the hard way, ever. I can but takes 100% full documentation..

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
03-08-2017, 05:49 AM (This post was last modified: 03-08-2017 05:49 AM by loe92.)
Post: #19
RE: 1.6 Swap Injecton problem
(03-08-2017 05:32 AM)fixkick Wrote:  
(03-08-2017 05:00 AM)loe92 Wrote:  
(03-05-2017 04:10 AM)fixkick Wrote:  thanks for sharing body tags photos. great examples.!!!

IT'S ME AGAIN Smile

I Called the guy who sold me the ECU, I can buy from him the right dizzy for 40 bucks, 33100-56B11, it has 4 pins.

Is there a way to connect this on the original samurai harness, just to try if it can works (the original samy distributor has 3 wires)?

I'll anyway buy a 1.6 vitara harness (even if the hunting will take a long time for sure), the guy will me send the VIN code of his car, and i will be able to find the right harness to put on my car.

sorry i have no USA sammi books for 94 only the one EFI drawing
and for sure no, EU books, for Sammi, harnesses... (only parts lists)

so you are attempting to cross wire 56b ecu to a 81C70 harness, hooo hooo,, "trumpets blaring"

wow, that is a hard row to hoe?

id have both books on both cars side by side. both full service manuals .
really hard and now you get to make the 56b ECU happy with all matching sensors, and actuators.

ouch. (way out of my pay-grade and books)

sorry

we move engines and all parts, and harnessed to the new car, not doing this the hard way, ever. I can but takes 100% full documentation..

Do you have in usa 4 wires DIZZIES? If i you have a diagram or a part of the diagrams i am sure that i can see what the fourth wire is for.
Find all posts by this user
Quote this message in a reply
03-08-2017, 06:12 AM
Post: #20
RE: 1.6 Swap Injecton problem
our 8v are all 3 wire
power
ground
cmp out.

keep i mind EPA banned here, TBI in 1992/3. calif, and after 1995, FED.

our early ECU is 2 pins. coil and power.
it makes its own spark and advance and has no CMP.

our newest sammi are all 3 wire. every one,

if I look in the parts list yours (some) had 2 wire, mag coils inside, a mag rotor and 2 wire to the coil, a pure Faraday setup> or Hall, not sure. but wildly different.

http://fixkick.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)